buildgcc: Fix colors for dash
[coreboot.git] / util / nvramtool / nvramtool.spec
1 ##
2
3 Name:    nvramtool
4 Version: 2.1
5 Release: 0
6
7 Summary: coreboot utility program
8 Group:   System Environment/Base
9 License: GPL
10 Provides: nvramtool
11
12 BuildRoot: %{_tmppath}/%{name}-%{version}
13
14 Source0: %{name}-%{version}.tgz
15
16 %description
17 nvramtool is a utility for reading/writing coreboot parameters and displaying
18 information from the coreboot table.
19
20 At boot time, coreboot places a table (known as the coreboot table) in low
21 physical memory.  The contents of this table are preserved even after
22 coreboot transfers control to the kernel and the kernel initializes itself.
23 The coreboot table contains various system information such as the type of
24 mainboard in use.  It also specifies locations in the CMOS (nonvolatile RAM)
25 where the coreboot parameters are stored.
26
27 %prep
28 %setup -n %{name}-%{version}
29
30 %build
31 make
32
33 %install
34 rm -rf "$RPM_BUILD_ROOT"
35 mkdir -p "$RPM_BUILD_ROOT/usr/bin"
36 mkdir -p "$RPM_BUILD_ROOT/usr/man/man8"
37 cp nvramtool "$RPM_BUILD_ROOT/usr/bin"
38 cp nvramtool.8.gz $RPM_BUILD_ROOT/usr/man/man8
39
40 %clean
41 rm -rf "$RPM_BUILD_ROOT"
42
43 %files
44 %defattr(-,root,root,0755)
45 %doc ChangeLog README
46 %doc README
47 /usr/bin/nvramtool
48 /usr/man/man8/nvramtool.8.gz