x11 stuff...
[archlinuxppc.git] / lhs2tex / PKGBUILD
1 # Maintainer: Arch Haskell Team <arch-haskell@haskell.org>
2 _hkgname=lhs2tex
3 pkgname=lhs2tex
4 pkgver=1.16
5 pkgrel=1
6 pkgdesc="Preprocessor for typesetting Haskell sources with LaTeX"
7 url="http://hackage.haskell.org/package/${_hkgname}"
8 license=('GPL')
9 arch=('i686' 'x86_64' 'ppc')
10 makedepends=('ghc' 'haskell-directory' 'haskell-extensible-exceptions' 'haskell-filepath' 'haskell-mtl' 'haskell-process' 'haskell-regex-compat')
11 depends=('gmp')
12 options=('strip')
13 source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 build() {
15     cd ${srcdir}/${_hkgname}-${pkgver}
16         ghc --make Setup.hs
17     ./Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O
18     ./Setup build
19 }
20 package() {
21     cd ${srcdir}/${_hkgname}-${pkgver}
22     ./Setup copy --destdir=${pkgdir}
23 }
24 md5sums=('d9a328cf54341a6722715411a195c2cc')