d537f8a82e0d4f73adf70bd8873f645eaa72d527
[archlinuxppc.git] / happy / PKGBUILD
1 # $Id: PKGBUILD 88454 2010-08-23 18:41:57Z vesa $
2 # Maintainer: simo <simo@archlinux.org>
3 # Contributor: Vesa Kaihlavirta <vegai@iki.fi>
4  
5 pkgname=happy
6 pkgver=1.18.5
7 pkgrel=1
8 pkgdesc="The Parser Generator for Haskell"
9 url="http://www.haskell.org/happy/"
10 arch=('i686' 'x86_64' 'ppc')
11 license=("custom:BSD3")
12 depends=(gmp)
13 makedepends=(ghc haskell-mtl)
14 options=(strip)
15 source=(http://hackage.haskell.org/packages/archive/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz)
16
17
18 build() {
19   cd $startdir/src/${pkgname}-${pkgver}
20
21   runhaskell Setup.lhs configure --prefix=/usr || return 1
22   runhaskell Setup.lhs build || return 1
23   runhaskell Setup.lhs copy --destdir=$startdir/pkg || return 1
24
25   install -D -m644 LICENSE $startdir/pkg/usr/share/licenses/$pkgname/LICENSE
26 }
27 md5sums=('9e77b67df7b6a4d7273383cc890f39e8')