darcs
[archlinuxppc.git] / ghc / PKGBUILD
1 # $Id: PKGBUILD 87335 2010-08-12 12:32:29Z vesa $
2 # Maintainer: Vesa Kaihlavirta <vesa@archlinux.org>
3 pkgname=ghc
4 pkgver=6.12.3
5 pkgrel=1
6 pkgdesc="The Glasgow Haskell Compiler"
7 arch=(i686 x86_64 ppc)
8 url="http://www.haskell.org/ghc/"
9 license=("custom")
10 depends=('perl' 'gmp>=5.0' gcc)
11 makedepends=(perl)
12 provides=("haskell-array=0.3.0.1"
13           "haskell-bytestring=0.9.1.7"
14           "haskell-cabal=1.8.0.6"
15           "haskell-containers=0.3.0.0"
16           "haskell-directory=1.0.1.1"       
17           "haskell-extensible-exceptions=0.1.1.1"
18           "haskell-filepath=1.1.0.4"
19           "haskell-haskell98=1.0.1.1"
20           "haskell-hpc=0.5.0.5"
21           "haskell-old-locale=1.0.0.2"
22           "haskell-old-time=1.0.0.5"
23           "haskell-pretty=1.0.1.1"
24           "haskell-process=1.0.1.3"
25           "haskell-random=1.0.0.2"
26           "haskell-syb=0.1.0.2"
27           "haskell-template-haskell=2.4.0.1"
28           "haskell-time=1.1.4"
29           "haskell-unix=2.4.0.2"
30           "haddock=2.6.0"
31          )
32 replaces=("haskell-array<0.3.0.1" 
33           "haskell-bytestring<0.9.1.7"
34           "haskell-cabal<1.8.0.6"
35           "haskell-containers<0.3.0.0"
36           "haskell-directory<1.0.1.1"
37           "haskell-extensible-exceptions<0.1.1.1"
38           "haskell-filepath<1.1.0.4"
39           "haskell-haskell98<1.0.1.1"
40           "haskell-hpc<0.5.0.5"
41           "haskell-old-locale<1.0.0.2"
42           "haskell-old-time<1.0.0.5"
43           "haskell-pretty<1.0.1.1"
44           "haskell-process<1.0.1.3"
45           "haskell-random<1.0.0.2"
46           "haskell-syb<0.1.0.2"
47           "haskell-template-haskell<2.4.0.1"
48           "haskell-time<1.1.4"
49           "haskell-unix<2.4.0.2"
50           "haddock<2.6.0"
51          )
52
53 backup=(usr/lib/ghc-6.12.3/package.conf)
54 install=ghc.install
55
56 source=("http://darcs.haskell.org/download/dist/$pkgver/$pkgname-$pkgver-src.tar.bz2" \
57         build.mk config.mk)
58
59 build() {
60   cd $srcdir/$pkgname-$pkgver
61
62   cp $srcdir/build.mk mk/build.mk
63   cp $srcdir/config.mk mk/config.mk
64
65   ./configure --prefix=/usr 
66   make -j1 || return 1
67   make DESTDIR=$pkgdir install
68
69   install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/ghc/license
70 }
71 md5sums=('4c2663c2eff833d7b9f39ef770eefbd6'
72          '5a3e0880c80b1dcecf779ff2e63a9c0d'
73          '0a9925d9710696d260bc9338ca7d39cf')