Merge pull request #5714 from alexischr/update_bockbuild
[mono.git] / support / Makefile.am
index 802b606670b4930e3880e0fb7d04ac3e710130f8..969ff60e4db002c8b5abe4f7360b1b48a6add11b 100644 (file)
@@ -26,7 +26,6 @@ MPH_C_SOURCE =                                        \
 # Source code which helps implement POSIX and other related Unix standards,
 # and *may* be portable between Unix platforms.
 MPH_UNIX_SOURCE =                              \
-       fakepoll.h                              \
        dirent.c                                \
        fcntl.c                                 \
        fstab.c                                 \
@@ -40,10 +39,12 @@ MPH_UNIX_SOURCE =                           \
        serial.c                                \
        sys-mman.c                              \
        sys-sendfile.c                          \
+       sys-socket.c                            \
        sys-stat.c                              \
        sys-statvfs.c                           \
        sys-time.c                              \
        sys-uio.c                               \
+       sys-uio.h                               \
        sys-utsname.c   \
        sys-wait.c                              \
        sys-xattr.c                             \
@@ -136,12 +137,14 @@ refresh:
        --impl-macro=_GNU_SOURCE --impl-macro=_XOPEN_SOURCE   \
        --impl-header="<sys/types.h>"                         \
        --impl-header="<sys/stat.h>"                          \
+       --autoconf-header="<netinet/in.h>"                    \
        --autoconf-header="<sys/time.h>"                      \
        --autoconf-header="<sys/poll.h>"                      \
        --autoconf-header="<sys/wait.h>"                      \
        --autoconf-header="<sys/statvfs.h>"                   \
        --autoconf-header="<sys/xattr.h>"                     \
        --autoconf-header="<sys/mman.h>"                      \
+       --autoconf-header="<sys/socket.h>"                    \
        --autoconf-header="<sys/uio.h>"                       \
        --autoconf-header="<unistd.h>"                        \
        --impl-header="<fcntl.h>"                             \
@@ -159,7 +162,7 @@ refresh:
        --rename-member=st_mtime=st_mtime_                    \
        --rename-namespace=Mono.Unix.Native=Mono.Posix        \
        --library=MonoPosixHelper                             \
-       $(mcs_topdir)/class/lib/net_4_5/Mono.Posix.dll map
+       $(mcs_topdir_from_srcdir)/class/lib/net_4_x/Mono.Posix.dll map
 
 # Useful if mono is compiled with --enable-shared=no
 patch-libtool: