Add new profile for monodroid tools (#5699)
[mono.git] / runtime / Makefile.am
index d9fcbdac16bf73db266acd72e7945b29d51f0408..2cd119314fe8290f26f5a6eb6712b2a51f97cd6d 100644 (file)
@@ -33,7 +33,7 @@ net_profile = net_4_x
 endif
 
 if INSTALL_MONODROID
-build_profiles += monodroid
+build_profiles += monodroid monodroid_tools
 endif
 
 if INSTALL_MONOTOUCH
@@ -48,19 +48,31 @@ if INSTALL_MONOTOUCH_TV
 build_profiles += monotouch_tv monotouch_tv_runtime
 endif
 
-if INSTALL_AOT_HYBRID
-build_profiles += aot_hybrid
+if INSTALL_TESTING_AOT_HYBRID
+build_profiles += testing_aot_hybrid
 endif
 
 if INSTALL_TESTING_AOT_FULL
 build_profiles += testing_aot_full
 endif
 
+if INSTALL_WINAOT
+build_profiles += winaot
+endif
+
 if INSTALL_XAMMAC
 build_profiles += xammac xammac_net_4_5
 endif
 
-test_profiles = $(build_profiles)
+if INSTALL_ORBIS
+build_profiles += orbis
+endif
+
+if INSTALL_UNREAL
+build_profiles += unreal
+endif
+
+test_profiles = $(filter-out binary_reference_assemblies monodroid_tools,$(build_profiles))
 
 if BUILD_MCS
 
@@ -113,25 +125,26 @@ cur_dir_cmd = pwd
 PLATFORM_PATH_SEPARATOR = :
 endif
 
-if INSTALL_TESTING_AOT_FULL
+# assemblies which are excluded from testing in mcs-compileall below
+VERIFY_TESTS_FILTER =
+
+if HOST_WIN32
+# Mono.WebBrowser.dll fails to verify on Windows
+VERIFY_TESTS_FILTER += Mono.WebBrowser.dll
+endif
+
+if FULL_AOT_TESTS
 #  ILASM.exe has features which a testing_aot_full runtime will not support.
 #  It is invoked with an external mono when used in the runtime.
 #  We skip it here because otherwise it will fail to verify.
-TESTING_AOT_FULL_FILTER=grep -v ilasm
-else
-TESTING_AOT_FULL_FILTER=echo
+VERIFY_TESTS_FILTER += ilasm.exe
 endif
 
 # Compile all assemblies with the verifier turned on. Code must be valid but not verifiable.
 # TODO it would be nice to split assemblies without unsafe code to use the verifier with verifiable mode.
-# Skip binary_reference_assemblies because they contain metadata only
 mcs-compileall: mono-wrapper etc/mono/config
-       export verifiable_files=`ls "$(mcs_topdir)/class/lib/$$profile/" | grep -E '\.(dll|exe)$$' | $(TESTING_AOT_FULL_FILTER)` ; \
        save_MONO_PATH=$$MONO_PATH; mcs_topdir=`cd $(mcs_topdir) && $(cur_dir_cmd)`; ok=:; \
        for profile in $(test_profiles); do \
-         if [ "binary_reference_assemblies" = "$$profile" ]; then \
-          continue; \
-      fi; \
          if [ "xbuild_12" = "$$profile" ]; then \
                  MONO_PATH="$$mcs_topdir/class/lib/$$profile$(PLATFORM_PATH_SEPARATOR)$$mcs_topdir/class/lib/net_4_x$(PLATFORM_PATH_SEPARATOR)$$save_MONO_PATH"; \
          elif [ "xbuild_14" = "$$profile" ]; then \
@@ -139,6 +152,7 @@ mcs-compileall: mono-wrapper etc/mono/config
          else \
                  MONO_PATH="$$mcs_topdir/class/lib/$$profile$(PLATFORM_PATH_SEPARATOR)$$save_MONO_PATH"; \
          fi; \
+         export verifiable_files=`ls "$(mcs_topdir)/class/lib/$$profile/" | grep -E '\.(dll|exe)$$' $(foreach asm,$(VERIFY_TESTS_FILTER), | grep -v $(asm))` ; \
          export MONO_PATH; \
          for stub in $$verifiable_files; do \
          i=$(mcs_topdir)/class/lib/$$profile/$$stub ; \
@@ -151,14 +165,11 @@ mcs-compileall: mono-wrapper etc/mono/config
            else \
              echo $$i verification failed; ok=false; \
            fi; done; done; \
+       if [ "$$ok" = "false" ]; then echo "<?xml version='1.0' encoding='utf-8'?><test-results failures='1' total='1' not-run='0' name='verify' date='$$(date +%F)' time='$$(date +%T)'><test-suite name='mcs-compileall' success='False' time='0'><results><test-case name='fail' executed='True' success='False' time='0'><failure><message>Verifying framework assemblies failed. Check the log for more details.</message><stack-trace></stack-trace></failure></test-case></results></test-suite></test-results>" > TestResult-verify.xml; fi; \
        $$ok
 
-if NACL_CODEGEN
-check-local:
-else
 check-local: mcs-compileall mcs-do-test-profiles
        $(MAKE) mcs-do-run-test-profiles
-endif
 
 # Compile all mcs tests
 test: mcs-do-test-profiles