Initial set of Ward sgen annotations (#5705)
[mono.git] / mono / utils / Makefile.am
index 20c9c45d01601f28f31cd352ec3be368b130d4ef..94416bc95372b9022f653cdcabf5d5bc4eefa38c 100644 (file)
@@ -13,7 +13,8 @@ endif
 
 if HOST_WIN32
 win32_sources = \
-       os-event-win32.c
+       os-event-win32.c \
+       mono-os-wait-win32.c
 
 platform_sources = $(win32_sources)
 else
@@ -39,6 +40,7 @@ monoutils_sources = \
        mono-dl-windows.c       \
        mono-dl-darwin.c        \
        mono-dl-posix.c         \
+       mono-dl-wasm.c  \
        mono-dl.h               \
        mono-dl-windows-internals.h     \
        mono-log-windows.c      \
@@ -59,6 +61,8 @@ monoutils_sources = \
        mono-mmap-internals.h   \
        mono-mmap-windows-internals.h   \
        mono-os-mutex.h         \
+       mono-os-mutex.c         \
+       mono-os-wait.h \
        mono-coop-mutex.h               \
        mono-once.h             \
        mono-lazy-init.h                \
@@ -134,6 +138,8 @@ monoutils_sources = \
        mono-threads-netbsd.c   \
        mono-threads-openbsd.c  \
        mono-threads-android.c  \
+       mono-threads-haiku.c    \
+       mono-threads-wasm.c     \
        mono-threads.h  \
        mono-threads-debug.h    \
        mono-threads-api.h      \
@@ -153,8 +159,6 @@ monoutils_sources = \
        mono-signal-handler.h   \
        mono-conc-hashtable.h   \
        mono-conc-hashtable.c   \
-       sha1.h          \
-       sha1.c  \
        json.h  \
        json.c  \
        networking.c    \
@@ -174,7 +178,10 @@ monoutils_sources = \
        checked-build.c \
        checked-build.h \
        os-event.h \
-       refcount.h
+       refcount.h      \
+       w32api.h        \
+       unlocked.h      \
+       ward.h
 
 arch_sources = 
 
@@ -240,14 +247,14 @@ if SPARC64
 arch_sources += mono-hwcap-sparc.c
 endif
 
-if IA64
-arch_sources += mono-hwcap-ia64.c
-endif
-
 if S390X
 arch_sources += mono-hwcap-s390x.c
 endif
 
+if HOST_WASM
+arch_sources += mono-hwcap-wasm.c
+endif
+
 else
 
 arch_sources += mono-hwcap-cross.c