[runtime] Avoid building a separate static library, use the shared object files for...
[mono.git] / mono / sgen / Makefile.am
index 6027f7839a7faebb48ac492b3b10b15966b7d38a..542bd836b4a4c60324638eba228b96d9d8ea7d4e 100644 (file)
@@ -8,7 +8,7 @@ if SHARED_MONO
 shared_libraries = libmonosgen.la
 endif
 endif
-libraries = $(shared_libraries) libmonosgen-static.la
+libraries = $(shared_libraries)
 endif
 
 if DISABLE_EXECUTABLES
@@ -72,7 +72,3 @@ monosgen_sources = \
 
 libmonosgen_la_SOURCES = $(monosgen_sources)
 libmonosgen_la_CFLAGS = $(SGEN_DEFINES)
-
-libmonosgen_static_la_SOURCES = $(libmonosgen_la_SOURCES)
-libmonosgen_static_la_CFLAGS = $(SGEN_DEFINES)
-libmonosgen_static_la_LDFLAGS = -static