[profiler] log profiler: limit method instrumentation to selected methods (#5517)
[mono.git] / mono / metadata / Makefile.am
index d90f9200ab0417b4178689dd293208d5e47ace00..8a9494054d94eaf9124c9c2731160131de14af16 100644 (file)
@@ -59,7 +59,7 @@ unix_sources = \
 platform_sources = $(unix_sources)
 endif
 
-if PLATFORM_ANDROID
+if HOST_ANDROID
 platform_sources += ../../support/libm/complex.c
 endif
 
@@ -223,7 +223,6 @@ common_sources = \
        w32process.h            \
        w32process-internals.h          \
        profiler.c              \
-       profiler-events.h       \
        profiler-private.h      \
        rand.h                  \
        rand.c                  \
@@ -282,7 +281,11 @@ common_sources = \
        sre.c   \
        sre-encode.c    \
        sre-save.c      \
-       custom-attrs.c
+       custom-attrs.c  \
+       fdhandle.h      \
+       fdhandle.c      \
+       callspec.h      \
+       callspec.c
 
 # These source files have compile time dependencies on GC code
 gc_dependent_sources = \
@@ -349,6 +352,7 @@ libmonoruntimeinclude_HEADERS = \
        object.h                \
        opcodes.h               \
        profiler.h              \
+       profiler-events.h       \
        reflection.h            \
        row-indexes.h           \
        tokentype.h             \