[profiler] log profiler: limit method instrumentation to selected methods (#5517)
[mono.git] / mono / metadata / Makefile.am
index 7f4a2bbdc6677dd6f4bb7322e4b2c4d1ea84e13c..8a9494054d94eaf9124c9c2731160131de14af16 100644 (file)
@@ -59,7 +59,7 @@ unix_sources = \
 platform_sources = $(unix_sources)
 endif
 
-if PLATFORM_ANDROID
+if HOST_ANDROID
 platform_sources += ../../support/libm/complex.c
 endif
 
@@ -127,6 +127,8 @@ null_gc_sources = \
 
 common_sources = \
        $(platform_sources)     \
+       appdomain.c     \
+       domain.c        \
        appdomain-icalls.h      \
        assembly.c              \
        assembly-internals.h    \
@@ -209,6 +211,7 @@ common_sources = \
        number-formatter.h      \
        number-ms.c             \
        number-ms.h             \
+       object.c        \
        object-internals.h      \
        opcodes.c               \
        property-bag.h  \
@@ -272,25 +275,25 @@ common_sources = \
        w32handle-namespace.c   \
        w32handle.h     \
        w32handle.c     \
-       w32error.h
+       w32error.h      \
+       reflection.c    \
+       dynamic-image.c \
+       sre.c   \
+       sre-encode.c    \
+       sre-save.c      \
+       custom-attrs.c  \
+       fdhandle.h      \
+       fdhandle.c      \
+       callspec.h      \
+       callspec.c
 
 # These source files have compile time dependencies on GC code
 gc_dependent_sources = \
-       appdomain.c     \
-       domain.c        \
        gc-stats.c      \
        gc.c            \
        monitor.c       \
        mono-hash.c     \
-       mono-conc-hash.c        \
-       object.c        \
-       dynamic-image.c \
-       sre.c   \
-       sre-encode.c    \
-       sre-save.c      \
-       custom-attrs.c  \
-       reflection.c
-
+       mono-conc-hash.c
 
 boehm_sources = \
        boehm-gc.c
@@ -349,6 +352,7 @@ libmonoruntimeinclude_HEADERS = \
        object.h                \
        opcodes.h               \
        profiler.h              \
+       profiler-events.h       \
        reflection.h            \
        row-indexes.h           \
        tokentype.h             \