[profiler] log profiler: limit method instrumentation to selected methods (#5517)
[mono.git] / mono / metadata / Makefile.am
index 6a229a87a31582c6a8fe1304a840fd88ffd2d5a6..8a9494054d94eaf9124c9c2731160131de14af16 100644 (file)
@@ -2,8 +2,9 @@ if HOST_WIN32
 win32_sources = \
        console-win32.c \
        console-win32-internals.h \
-       file-io-windows.c \
-       file-io-windows-internals.h \
+       cominterop-win32-internals.h \
+       w32file-win32.c \
+       w32file-win32-internals.h \
        icall-windows.c \
        icall-windows-internals.h \
        marshal-windows.c \
@@ -15,7 +16,8 @@ win32_sources = \
        w32event-win32.c \
        w32process-win32.c \
        w32process-win32-internals.h \
-       socket-io-windows.c
+       w32socket-win32.c \
+       w32error-win32.c
 
 platform_sources = $(win32_sources)
 
@@ -47,12 +49,17 @@ unix_sources = \
        w32process-unix-osx.c \
        w32process-unix-bsd.c \
        w32process-unix-haiku.c \
-       w32process-unix-default.c
+       w32process-unix-default.c \
+       w32socket-unix.c \
+       w32file-unix.c \
+       w32file-unix-glob.c \
+       w32file-unix-glob.h \
+       w32error-unix.c
 
 platform_sources = $(unix_sources)
 endif
 
-if PLATFORM_ANDROID
+if HOST_ANDROID
 platform_sources += ../../support/libm/complex.c
 endif
 
@@ -114,10 +121,14 @@ null_sources = \
        console-null.c
 
 null_gc_sources = \
-       null-gc.c
+       null-gc.c \
+       null-gc-handles.h \
+       null-gc-handles.c
 
 common_sources = \
        $(platform_sources)     \
+       appdomain.c     \
+       domain.c        \
        appdomain-icalls.h      \
        assembly.c              \
        assembly-internals.h    \
@@ -149,9 +160,9 @@ common_sources = \
        exception.c             \
        exception.h             \
        exception-internals.h   \
-       file-io.c               \
-       file-io.h               \
-       file-io-internals.h \
+       w32file.c               \
+       w32file.h               \
+       w32file-internals.h \
        filewatcher.c           \
        filewatcher.h           \
        gc-internals.h          \
@@ -182,10 +193,11 @@ common_sources = \
        mono-config.c           \
        mono-debug.h            \
        mono-debug.c            \
-       mono-debug-debugger.h   \
+       debug-internals.h       \
        mono-endian.c           \
        mono-endian.h           \
        mono-hash.h             \
+       mono-conc-hash.h                \
        mono-mlist.c            \
        mono-mlist.h            \
        mono-perfcounters.c     \
@@ -195,17 +207,18 @@ common_sources = \
        mono-route.c            \
        mono-route.h            \
        monitor.h               \
-       nacl-stub.c             \
        normalization-tables.h  \
        number-formatter.h      \
        number-ms.c             \
        number-ms.h             \
+       object.c        \
        object-internals.h      \
        opcodes.c               \
        property-bag.h  \
        property-bag.c  \
-       socket-io.c             \
-       socket-io.h             \
+       w32socket.c             \
+       w32socket.h             \
+       w32socket-internals.h           \
        w32process.c            \
        w32process.h            \
        w32process-internals.h          \
@@ -229,10 +242,12 @@ common_sources = \
        tabledefs.h             \
        threads.c               \
        threads-types.h         \
-       threadpool-ms.c \
-       threadpool-ms.h \
-       threadpool-ms-io.c      \
-       threadpool-ms-io.h      \
+       threadpool.c    \
+       threadpool.h    \
+       threadpool-worker-default.c     \
+       threadpool-worker.h     \
+       threadpool-io.c \
+       threadpool-io.h \
        verify.c                \
        verify-internals.h      \
        wrapper-types.h \
@@ -259,24 +274,26 @@ common_sources = \
        w32handle-namespace.h   \
        w32handle-namespace.c   \
        w32handle.h     \
-       w32handle.c
+       w32handle.c     \
+       w32error.h      \
+       reflection.c    \
+       dynamic-image.c \
+       sre.c   \
+       sre-encode.c    \
+       sre-save.c      \
+       custom-attrs.c  \
+       fdhandle.h      \
+       fdhandle.c      \
+       callspec.h      \
+       callspec.c
 
 # These source files have compile time dependencies on GC code
 gc_dependent_sources = \
-       appdomain.c     \
-       domain.c        \
        gc-stats.c      \
        gc.c            \
        monitor.c       \
        mono-hash.c     \
-       object.c        \
-       dynamic-image.c \
-       sre.c   \
-       sre-encode.c    \
-       sre-save.c      \
-       custom-attrs.c  \
-       reflection.c
-
+       mono-conc-hash.c
 
 boehm_sources = \
        boehm-gc.c
@@ -335,10 +352,11 @@ libmonoruntimeinclude_HEADERS = \
        object.h                \
        opcodes.h               \
        profiler.h              \
+       profiler-events.h       \
        reflection.h            \
        row-indexes.h           \
        tokentype.h             \
        verify.h                
 
 EXTRA_DIST = $(win32_sources) $(unix_sources) $(null_sources) runtime.h \
-               threadpool-ms-io-poll.c threadpool-ms-io-epoll.c threadpool-ms-io-kqueue.c sgen-dynarray.h
+               threadpool-io-poll.c threadpool-io-epoll.c threadpool-io-kqueue.c sgen-dynarray.h