[profiler] log profiler: limit method instrumentation to selected methods (#5517)
[mono.git] / mono / metadata / Makefile.am
index 49f7ea0f44b7f6e2172e01858a5981cbc894d3cc..8a9494054d94eaf9124c9c2731160131de14af16 100644 (file)
@@ -1,10 +1,23 @@
 if HOST_WIN32
 win32_sources = \
        console-win32.c \
+       console-win32-internals.h \
+       cominterop-win32-internals.h \
+       w32file-win32.c \
+       w32file-win32-internals.h \
+       icall-windows.c \
+       icall-windows-internals.h \
+       marshal-windows.c \
+       marshal-windows-internals.h \
+       mono-security-windows.c \
+       mono-security-windows-internals.h \
        w32mutex-win32.c \
        w32semaphore-win32.c \
        w32event-win32.c \
-       socket-io-windows.c
+       w32process-win32.c \
+       w32process-win32-internals.h \
+       w32socket-win32.c \
+       w32error-win32.c
 
 platform_sources = $(win32_sources)
 
@@ -30,23 +43,26 @@ unix_sources = \
        console-unix.c \
        w32mutex-unix.c \
        w32semaphore-unix.c \
-       w32event-unix.c
+       w32event-unix.c \
+       w32process-unix.c \
+       w32process-unix-internals.h \
+       w32process-unix-osx.c \
+       w32process-unix-bsd.c \
+       w32process-unix-haiku.c \
+       w32process-unix-default.c \
+       w32socket-unix.c \
+       w32file-unix.c \
+       w32file-unix-glob.c \
+       w32file-unix-glob.h \
+       w32error-unix.c
 
 platform_sources = $(unix_sources)
 endif
 
-if PLATFORM_ANDROID
+if HOST_ANDROID
 platform_sources += ../../support/libm/complex.c
 endif
 
-if BTLS
-btls_file_list := $(shell cat ../btls/build-shared/mono-btls-shared-lo.txt)
-btls_static_file_list := $(shell cat ../btls/build-static/mono-btls-static-lo.txt)
-btls_libs = $(btls_file_list)
-btls_static_libs = $(btls_static_file_list)
-btls_cflags = -I$(top_srcdir)/external/boringssl/include -I$(top_srcdir)/mono/btls
-endif
-
 #
 # libtool is not capable of creating static/shared versions of the same
 # convenience lib, so we have to do it ourselves
@@ -79,7 +95,7 @@ else
 noinst_LTLIBRARIES = libmonoruntime-config.la $(boehm_libraries) $(sgen_libraries)
 endif
 
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/mono $(LIBGC_CPPFLAGS) $(GLIB_CFLAGS) $(SHARED_CFLAGS) $(btls_cflags)
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/mono $(LIBGC_CPPFLAGS) $(GLIB_CFLAGS) $(SHARED_CFLAGS)
 
 #
 # Make sure any prefix changes are updated in the binaries too.
@@ -97,7 +113,7 @@ mono-config-dirs.lo: Makefile
 libmonoruntime_config_la_SOURCES = \
        mono-config-dirs.h              \
        mono-config-dirs.c
-libmonoruntime_config_la_CPPFLAGS = $(AM_CPPFLAGS) -DMONO_BINDIR=\"$(bindir)/\" -DMONO_ASSEMBLIES=\"$(assembliesdir)\" -DMONO_CFG_DIR=\"$(confdir)\"
+libmonoruntime_config_la_CPPFLAGS = $(AM_CPPFLAGS) -DMONO_BINDIR=\"$(bindir)/\" -DMONO_ASSEMBLIES=\"$(assembliesdir)\" -DMONO_CFG_DIR=\"$(confdir)\" -DMONO_RELOC_LIBDIR=\"../$(reloc_libdir)\"
 
 CLEANFILES = mono-bundle.stamp
 
@@ -105,10 +121,15 @@ null_sources = \
        console-null.c
 
 null_gc_sources = \
-       null-gc.c
+       null-gc.c \
+       null-gc-handles.h \
+       null-gc-handles.c
 
 common_sources = \
        $(platform_sources)     \
+       appdomain.c     \
+       domain.c        \
+       appdomain-icalls.h      \
        assembly.c              \
        assembly-internals.h    \
        attach.h                \
@@ -116,11 +137,14 @@ common_sources = \
        cil-coff.h              \
        class.c                 \
        class-internals.h       \
+       class-inlines.h         \
+       class-accessors.c       \
        cominterop.c            \
        cominterop.h            \
        console-io.h            \
        coree.c                 \
        coree.h                 \
+       coree-internals.h \
        culture-info.h          \
        culture-info-tables.h   \
        debug-helpers.c         \
@@ -136,12 +160,14 @@ common_sources = \
        exception.c             \
        exception.h             \
        exception-internals.h   \
-       file-io.c               \
-       file-io.h               \
+       w32file.c               \
+       w32file.h               \
+       w32file-internals.h \
        filewatcher.c           \
        filewatcher.h           \
        gc-internals.h          \
        icall.c                 \
+       icall-internals.h \
        icall-def.h             \
        image.c                 \
        image-internals.h       \
@@ -153,6 +179,7 @@ common_sources = \
        lock-tracer.h           \
        marshal.c               \
        marshal.h               \
+       marshal-internals.h \
        mempool.c               \
        mempool.h               \
        mempool-internals.h     \
@@ -166,10 +193,11 @@ common_sources = \
        mono-config.c           \
        mono-debug.h            \
        mono-debug.c            \
-       mono-debug-debugger.h   \
+       debug-internals.h       \
        mono-endian.c           \
        mono-endian.h           \
        mono-hash.h             \
+       mono-conc-hash.h                \
        mono-mlist.c            \
        mono-mlist.h            \
        mono-perfcounters.c     \
@@ -179,17 +207,21 @@ common_sources = \
        mono-route.c            \
        mono-route.h            \
        monitor.h               \
-       nacl-stub.c             \
        normalization-tables.h  \
        number-formatter.h      \
        number-ms.c             \
        number-ms.h             \
+       object.c        \
        object-internals.h      \
        opcodes.c               \
-       socket-io.c             \
-       socket-io.h             \
-       process.c               \
-       process.h               \
+       property-bag.h  \
+       property-bag.c  \
+       w32socket.c             \
+       w32socket.h             \
+       w32socket-internals.h           \
+       w32process.c            \
+       w32process.h            \
+       w32process-internals.h          \
        profiler.c              \
        profiler-private.h      \
        rand.h                  \
@@ -210,10 +242,12 @@ common_sources = \
        tabledefs.h             \
        threads.c               \
        threads-types.h         \
-       threadpool-ms.c \
-       threadpool-ms.h \
-       threadpool-ms-io.c      \
-       threadpool-ms-io.h      \
+       threadpool.c    \
+       threadpool.h    \
+       threadpool-worker-default.c     \
+       threadpool-worker.h     \
+       threadpool-io.c \
+       threadpool-io.h \
        verify.c                \
        verify-internals.h      \
        wrapper-types.h \
@@ -238,33 +272,33 @@ common_sources = \
        w32semaphore.h  \
        w32event.h      \
        w32handle-namespace.h   \
-       w32handle-namespace.c
+       w32handle-namespace.c   \
+       w32handle.h     \
+       w32handle.c     \
+       w32error.h      \
+       reflection.c    \
+       dynamic-image.c \
+       sre.c   \
+       sre-encode.c    \
+       sre-save.c      \
+       custom-attrs.c  \
+       fdhandle.h      \
+       fdhandle.c      \
+       callspec.h      \
+       callspec.c
 
 # These source files have compile time dependencies on GC code
 gc_dependent_sources = \
-       appdomain.c     \
-       domain.c        \
        gc-stats.c      \
        gc.c            \
        monitor.c       \
        mono-hash.c     \
-       object.c        \
-       dynamic-image.c \
-       sre.c   \
-       sre-encode.c    \
-       sre-save.c      \
-       custom-attrs.c  \
-       reflection.c
-
+       mono-conc-hash.c
 
 boehm_sources = \
        boehm-gc.c
 
 sgen_sources = \
-       sgen-os-posix.c         \
-       sgen-os-mach.c          \
-       sgen-os-win32.c         \
-       sgen-os-coop.c          \
        sgen-bridge.c           \
        sgen-bridge.h           \
        sgen-bridge-internals.h \
@@ -279,21 +313,21 @@ sgen_sources = \
 
 libmonoruntime_la_SOURCES = $(common_sources) $(gc_dependent_sources) $(null_gc_sources) $(boehm_sources)
 libmonoruntime_la_CFLAGS = $(BOEHM_DEFINES)
-libmonoruntime_la_LIBADD = libmonoruntime-config.la $(btls_libs)
+libmonoruntime_la_LIBADD = libmonoruntime-config.la
 
 libmonoruntimesgen_la_SOURCES = $(common_sources) $(gc_dependent_sources) $(sgen_sources)
 libmonoruntimesgen_la_CFLAGS = $(SGEN_DEFINES)
-libmonoruntimesgen_la_LIBADD = libmonoruntime-config.la $(btls_libs)
+libmonoruntimesgen_la_LIBADD = libmonoruntime-config.la
 
 libmonoruntime_static_la_SOURCES = $(libmonoruntime_la_SOURCES)
 libmonoruntime_static_la_LDFLAGS = -static
 libmonoruntime_static_la_CFLAGS = $(BOEHM_DEFINES)
-libmonoruntime_static_la_LIBADD = $(bundle_obj) libmonoruntime-config.la $(btls_static_libs)
+libmonoruntime_static_la_LIBADD = $(bundle_obj) libmonoruntime-config.la
 
 libmonoruntimesgen_static_la_SOURCES = $(libmonoruntimesgen_la_SOURCES)
 libmonoruntimesgen_static_la_LDFLAGS = -static
 libmonoruntimesgen_static_la_CFLAGS = $(SGEN_DEFINES)
-libmonoruntimesgen_static_la_LIBADD = libmonoruntime-config.la $(btls_static_libs)
+libmonoruntimesgen_static_la_LIBADD = libmonoruntime-config.la
 
 libmonoruntimeincludedir = $(includedir)/mono-$(API_VER)/mono/metadata
 
@@ -318,10 +352,11 @@ libmonoruntimeinclude_HEADERS = \
        object.h                \
        opcodes.h               \
        profiler.h              \
+       profiler-events.h       \
        reflection.h            \
        row-indexes.h           \
        tokentype.h             \
        verify.h                
 
 EXTRA_DIST = $(win32_sources) $(unix_sources) $(null_sources) runtime.h \
-               threadpool-ms-io-poll.c threadpool-ms-io-epoll.c threadpool-ms-io-kqueue.c sgen-dynarray.h
+               threadpool-io-poll.c threadpool-io-epoll.c threadpool-io-kqueue.c sgen-dynarray.h