[profiler] log profiler: limit method instrumentation to selected methods (#5517)
[mono.git] / mono / metadata / Makefile.am
index 2f760792a510e13512f905ef39e1034a57f111e0..8a9494054d94eaf9124c9c2731160131de14af16 100644 (file)
@@ -59,10 +59,14 @@ unix_sources = \
 platform_sources = $(unix_sources)
 endif
 
-if PLATFORM_ANDROID
+if HOST_ANDROID
 platform_sources += ../../support/libm/complex.c
 endif
 
+#
+# libtool is not capable of creating static/shared versions of the same
+# convenience lib, so we have to do it ourselves
+#
 if SUPPORT_SGEN
 if DISABLE_EXECUTABLES
 shared_sgen_libraries = libmonoruntimesgen.la 
@@ -71,7 +75,7 @@ if SHARED_MONO
 shared_sgen_libraries = libmonoruntimesgen.la 
 endif
 endif
-sgen_libraries = $(shared_sgen_libraries)
+sgen_libraries = $(shared_sgen_libraries) libmonoruntimesgen-static.la 
 endif
 
 if SUPPORT_BOEHM
@@ -82,7 +86,7 @@ if SHARED_MONO
 shared_boehm_libraries = libmonoruntime.la
 endif
 endif
-boehm_libraries = $(shared_boehm_libraries)
+boehm_libraries = $(shared_boehm_libraries) libmonoruntime-static.la
 endif
 
 if DISABLE_EXECUTABLES
@@ -279,7 +283,9 @@ common_sources = \
        sre-save.c      \
        custom-attrs.c  \
        fdhandle.h      \
-       fdhandle.c
+       fdhandle.c      \
+       callspec.h      \
+       callspec.c
 
 # These source files have compile time dependencies on GC code
 gc_dependent_sources = \
@@ -313,6 +319,16 @@ libmonoruntimesgen_la_SOURCES = $(common_sources) $(gc_dependent_sources) $(sgen
 libmonoruntimesgen_la_CFLAGS = $(SGEN_DEFINES)
 libmonoruntimesgen_la_LIBADD = libmonoruntime-config.la
 
+libmonoruntime_static_la_SOURCES = $(libmonoruntime_la_SOURCES)
+libmonoruntime_static_la_LDFLAGS = -static
+libmonoruntime_static_la_CFLAGS = $(BOEHM_DEFINES)
+libmonoruntime_static_la_LIBADD = $(bundle_obj) libmonoruntime-config.la
+
+libmonoruntimesgen_static_la_SOURCES = $(libmonoruntimesgen_la_SOURCES)
+libmonoruntimesgen_static_la_LDFLAGS = -static
+libmonoruntimesgen_static_la_CFLAGS = $(SGEN_DEFINES)
+libmonoruntimesgen_static_la_LIBADD = libmonoruntime-config.la
+
 libmonoruntimeincludedir = $(includedir)/mono-$(API_VER)/mono/metadata
 
 libmonoruntimeinclude_HEADERS = \