Merge pull request #5714 from alexischr/update_bockbuild
[mono.git] / mono / arch / Makefile.am
index e7700ed3a61a3439f3ec570b2ffc5e5f54a477c0..a5c81d135ec93b88704f4598018f7763cc360572 100644 (file)
@@ -1,25 +1,10 @@
-DIST_SUBDIRS = x86 ppc sparc arm s390x amd64 ia64 mips
+DIST_SUBDIRS = x86 ppc sparc arm arm64 s390x amd64 mips
 
 AM_CPPFLAGS = $(GLIB_CFLAGS) -I$(top_srcdir)
 
-if INTERP_SUPPORTED
-SUBDIRS = $(arch_target)
-else
 if ARM
 # arm needs to build some stuff even in JIT mode
 SUBDIRS = $(arch_target)
-endif
-endif
-
-if INTERP_SUPPORTED
-
-noinst_LTLIBRARIES = libmonoarch.la
-
-libmonoarch_la_SOURCES = unknown.c
-
-libmonoarch_la_LIBADD = $(arch_target)/libmonoarch-$(arch_target).la
-
 endif
 
-EXTRA_DIST = ChangeLog