codeowners update
[mono.git] / libgc / Makefile.am
index 735cc3bdaf8a9096974994326828aa520a329577..55cced5f5708da77d883b6ebf1dde2b093690f10 100644 (file)
 ## files that should be in the distribution are not mentioned in this
 ## Makefile.am.
 
-AUTOMAKE_OPTIONS = foreign
+ACLOCAL_AMFLAGS = -I m4
 
-SUBDIRS = include doc
+SUBDIRS = m4 include doc
 
-INCLUDES = -I$(top_builddir)/.. -I$(top_srcdir)/..
+AM_CPPFLAGS = -I$(top_builddir)/.. -I$(top_srcdir)/..
 
 #
 # libtool is not capable of creating shared/static versions of a convenience
@@ -36,8 +36,10 @@ EXTRA_DIST =
 
 if POWERPC_DARWIN
 asm_libgc_sources = powerpc_darwin_mach_dep.s
-else
-asm_libgc_sources = 
+endif
+
+if TARGET_IA64
+asm_libgc_sources = ia64_save_regs_in_stack.s
 endif
 
 libmonogc_la_SOURCES = allchblk.c alloc.c blacklst.c checksums.c dbg_mlc.c \
@@ -47,12 +49,12 @@ obj_map.c os_dep.c pcr_interface.c ptr_chck.c real_malloc.c reclaim.c \
 solaris_pthreads.c solaris_threads.c specific.c stubborn.c typd_mlc.c \
 backgraph.c win32_threads.c \
 pthread_support.c pthread_stop_world.c darwin_stop_world.c \
-$(asm_libgc_sources)
+openbsd_stop_world.c mach_dep.c $(asm_libgc_sources)
 
 # Include THREADDLLIBS here to ensure that the correct versions of
 # linuxthread semaphore functions get linked:
-libmonogc_la_LIBADD = @addobjs@ $(THREADDLLIBS) $(UNWINDLIBS)
-libmonogc_la_DEPENDENCIES = @addobjs@
+libmonogc_la_LIBADD = $(THREADDLLIBS) $(UNWINDLIBS)
+libmonogc_la_DEPENDENCIES =
 libmonogc_la_LDFLAGS = -version-info 1:2:0
 
 EXTRA_libmonogc_la_SOURCES = alpha_mach_dep.S \
@@ -66,7 +68,7 @@ libmonogc_static_la_LDFLAGS = -static
 
 EXTRA_DIST += alpha_mach_dep.S mips_sgi_mach_dep.s sparc_mach_dep.S
 
-AM_CFLAGS = @GC_CFLAGS@
+AM_CFLAGS = $(WERROR_CFLAGS) @GC_CFLAGS@
 
 if CPLUSPLUS
 extra_checks = test_cpp
@@ -93,7 +95,7 @@ endif
 #TESTS = gctest $(extra_checks)
 
 ## FIXME: relies on internal code generated by automake.
-all_objs = @addobjs@ $(libgc_la_OBJECTS)
+all_objs = $(libgc_la_OBJECTS)
 $(all_objs) : include/private/gcconfig.h include/private/gc_priv.h \
 include/private/gc_hdrs.h include/gc.h include/gc_gcj.h include/gc_mark.h
 
@@ -113,7 +115,7 @@ endif
 
 ## We have our own definition of LTCOMPILE because we want to use our
 ## CFLAGS, not those passed in from the top level make.
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) \
+LTCOMPILE = $(LIBTOOL) --mode=compile --tag=CC $(CC) $(DEFS) \
        -I$(top_srcdir)/include $(AM_CPPFLAGS) $(CPPFLAGS) \
        $(AM_CFLAGS) $(MY_CFLAGS) $(GC_CFLAGS) 
 LINK = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(MY_CFLAGS) $(LDFLAGS) -o $@
@@ -167,7 +169,7 @@ EXTRA_DIST += add_gc_prefix.c gcname.c if_mach.c if_not_there.c hpux_test_and_cl
 
 # cord package
 #
-EXTRA_DIST += cord/cordbscs.c cord/cordtest.c cord/de.c cord/de_win.c cord/de_win.ICO cord/cordprnt.c cord/cordxtra.c cord/de_cmds.h cord/de_win.h cord/de_win.RC
+EXTRA_DIST += cord cord/cordbscs.c cord/cordtest.c cord/de.c cord/de_win.c cord/de_win.ICO cord/cordprnt.c cord/cordxtra.c cord/de_cmds.h cord/de_win.h cord/de_win.RC
 
 # this is an auxiliary shell file used by Makefile and Makefile.direct
 #
@@ -182,3 +184,4 @@ EXTRA_DIST += configure.host
 # it will not remove dest if building fails
 .S.s:
        if $(CPP) $< >$@ ; then :; else rm -f $@; fi
+