Merge pull request #5714 from alexischr/update_bockbuild
[mono.git] / acceptance-tests / Makefile.am
index 6f4f2080ebffc935ddc04390ed266f5f7529581d..2e47df81bd03ae6dff89dc06c50abb7d2aa91dfa 100644 (file)
@@ -8,11 +8,12 @@ CLEANFILES = *.dll *.exe *.mdb
 EXTRA_DIST=README.md SUBMODULES.json versions.mk roslyn.mk coreclr.mk ms-test-suite.mk
 
 CLASS=$(mcs_topdir)/class/lib/$(DEFAULT_PROFILE)
+TOOLS_CLASS=$(mcs_topdir)/class/lib/build
 
-with_mono_path = MONO_PATH=$(CLASS)
-RUNTIME = $(with_mono_path) $(abs_top_builddir)/runtime/mono-wrapper --debug
-MCS = $(RUNTIME) $(CSC) -nologo
-ILASM = $(RUNTIME) $(CLASS)/ilasm.exe
+RUNTIME = MONO_PATH=$(CLASS) $(abs_top_builddir)/runtime/mono-wrapper --debug
+TOOLS_RUNTIME = MONO_PATH=$(TOOLS_CLASS) $(abs_top_builddir)/runtime/mono-wrapper --debug
+MCS = $(TOOLS_RUNTIME) $(CSC) -nologo -noconfig -lib:$(CLASS) -r:System.dll -r:System.Core.dll -r:System.Xml.dll -r:Microsoft.CSharp.dll
+ILASM = $(TOOLS_RUNTIME) $(TOOLS_CLASS)/ilasm.exe
 
 include versions.mk
 include profiler-stress.mk