* configure.ac: New switch for disabling -O2 (--disable-optimizations).
[cacao.git] / tests / Makefile.am
index c0e48a49f3dc3dbe1365e6fcad06fca9c7dbbde6..277918f423c702ee7df7f02d74eef0a42e7e1a33 100644 (file)
@@ -1,15 +1,47 @@
-EXTRA_DIST = x.java x.output jctest.java fptest.java
+## tests/Makefile.am
+##
+## Copyright (C) 1996-2005, 2006, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
+##
+## This file is part of CACAO.
+##
+## This program is free software; you can redistribute it and/or
+## modify it under the terms of the GNU General Public License as
+## published by the Free Software Foundation; either version 2, or (at
+## your option) any later version.
+##
+## This program is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+## General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+## 02110-1301, USA.
 
-check_DATA = checkall
 
-checkall: x.tst jctest.tst GCBench.tstrun
+JAVA     = LD_LIBRARY_PATH=$(top_builddir)/src/cacao/.libs $(top_builddir)/src/cacao/cacao
+JAVACMD  = $(JAVA) -Xbootclasspath:$(BOOTCLASSPATH)
+JAVACCMD = $(JAVAC) -bootclasspath $(BOOTCLASSPATH)
 
-%.tst:
-       ../cacao -ieee sun.tools.javac.Main $*.java
-       ../cacao -ieee $* >$*.thisoutput
-       diff --brief $*.thisoutput $*.output
-       rm -f $*.thisoutput
+SUBDIRS = \
+       regression
 
-%.tstrun:
-       ../cacao -ieee sun.tools.javac.Main $*.java
-       ../cacao -ieee $*
+EXTRA_DIST = \
+       $(srcdir)/*.java
+
+CLEANFILES = \
+       *.class
+
+build:
+       $(JAVACCMD) -d . $(srcdir)/*.java
+
+
+## Local variables:
+## mode: Makefile
+## indent-tabs-mode: t
+## c-basic-offset: 4
+## tab-width: 8
+## compile-command: "automake --add-missing"
+## End: