* configure.ac: New switch for disabling -O2 (--disable-optimizations).
[cacao.git] / tests / Makefile.am
index ad8d51d8fd97b1b46dd8736bda7792678fc2ed5e..277918f423c702ee7df7f02d74eef0a42e7e1a33 100644 (file)
@@ -1,9 +1,7 @@
 ## tests/Makefile.am
 ##
-## Copyright (C) 1996-2005 R. Grafl, A. Krall, C. Kruegel, C. Oates,
-## R. Obermaisser, M. Platter, M. Probst, S. Ring, E. Steiner,
-## C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich, J. Wenninger,
-## Institut f. Computersprachen - TU Wien
+## Copyright (C) 1996-2005, 2006, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
 ##
 ## This file is part of CACAO.
 ##
 ##
 ## You should have received a copy of the GNU General Public License
 ## along with this program; if not, write to the Free Software
-## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
-## 02111-1307, USA.
-##
-## Contact: cacao@complang.tuwien.ac.at
-##
-## Authors: Christian Thalinger
-##
-## Changes:
-##
-## $Id: Makefile.am 3004 2005-07-12 19:36:10Z twisti $
+## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+## 02110-1301, USA.
 
-## Process this file with automake to produce Makefile.in
 
-SUBDIRS = codepatching native
+JAVA     = LD_LIBRARY_PATH=$(top_builddir)/src/cacao/.libs $(top_builddir)/src/cacao/cacao
+JAVACMD  = $(JAVA) -Xbootclasspath:$(BOOTCLASSPATH)
+JAVACCMD = $(JAVAC) -bootclasspath $(BOOTCLASSPATH)
 
-EXTRA_DIST = \
-       x.java x.output \
-       jctest.java jctest.output \
-       fptest.java fptest.output \
-       fp.java fp.output \
-       extest.java extest.output extest.2output\
-       TestBase.java TestArrayClasses.java TestArrayClasses.output \
-       BasicToStrings.java BasicToStrings.output \
-       GCBench.java \
-       JavaPerformance.java \
-       param_test.java
-
-JAVA = $(top_builddir)/src/cacao/cacao
-JAVAC = jikes -nowarn
+SUBDIRS = \
+       regression
 
-checkall: x.tst jctest.tst fptest.tst fp.tst extest.tst TestArrayClasses.tst BasicToStrings.tst param_test.tst
+EXTRA_DIST = \
+       $(srcdir)/*.java
 
-%.tst:
-       $(JAVAC) $*.java
-       sh Test.sh $(JAVA) $*
-#      $(JAVA) $* > $*.thisoutput
-#      diff --brief $*.output $*.thisoutput
-       $(RM) $*.thisoutput
-       $(RM) $*.this2output
+CLEANFILES = \
+       *.class
 
-%.tstrun:
-       $(JAVAC) $*.java
-       $(JAVA) $*
+build:
+       $(JAVACCMD) -d . $(srcdir)/*.java
 
 
 ## Local variables: