- build/dist/install changes
[cacao.git] / src / vm / jit / powerpc / Makefile.am
index 3e12219ea72932a0b1497d62bb88db1112fd1e14..a0cbd1f9e47a11483282006a6bcd1e69ea4d5700 100644 (file)
@@ -1,20 +1,42 @@
-## Process this file with automake to produce Makefile.in
+## vm/jit/powerpc/Makefile.am
+##
+## Copyright (C) 1996-2005 R. Grafl, A. Krall, C. Kruegel, C. Oates,
+## R. Obermaisser, M. Platter, M. Probst, S. Ring, E. Steiner,
+## C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich, J. Wenninger,
+## TU Wien
+##
+## This file is part of CACAO.
+##
+## This program is free software; you can redistribute it and/or
+## modify it under the terms of the GNU General Public License as
+## published by the Free Software Foundation; either version 2, or (at
+## your option) any later version.
+##
+## This program is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+## General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+## 02111-1307, USA.
+##
+## Contact: cacao@complang.tuwien.ac.at
+##
+## Authors: Christian Thalinger
+##
+## Changes:
+##
+## $Id: Makefile.am 1676 2004-12-03 16:52:15Z twisti $
 
-# $Id: Makefile.am 1635 2004-12-01 09:57:58Z twisti $
+## Process this file with automake to produce Makefile.in
 
 INCLUDES = -I$(top_srcdir)/src
 
-EXTRA_DIST = \
-       asmpart.S \
-       codegen.c \
-       codegen.h \
-       dis-asm.h \
-       disass.c \
-       disass.h \
+noinst_HEADERS = \
+       arch.h \
        machine-instr.h \
-       ppc-dis.c \
-       ppc-opc.c
-       ppc.h \
        types.h
 
 noinst_LIBRARIES = libarch.a
@@ -22,9 +44,13 @@ noinst_LIBRARIES = libarch.a
 libarch_a_SOURCES = \
        asmpart.S \
        codegen.c \
+       codegen.h \
+       dis-asm.h \
        disass.c \
+       disass.h \
        ppc-dis.c \
-       ppc-opc.c
+       ppc-opc.c \
+       ppc.h
 
 asmpart.o: asmpart.S $(top_srcdir)/config.h offsets.h
        $(COMPILE) -c $<