* configure.ac: Some maintenance for make dist.
[cacao.git] / src / vm / jit / m68k / Makefile.am
index c761839cfe0bcef4464c19844b2ebd5cf7f4fb73..5ef248664b038acec92d579eb3fcf1b413ac3cd6 100644 (file)
@@ -1,4 +1,28 @@
-DIST_SUBDIRS = linux
+## src/vm/jit/m68k/Makefile.am
+##
+## Copyright (C) 2006, 2007, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
+##
+## This file is part of CACAO.
+##
+## This program is free software; you can redistribute it and/or
+## modify it under the terms of the GNU General Public License as
+## published by the Free Software Foundation; either version 2, or (at
+## your option) any later version.
+##
+## This program is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+## General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+## 02110-1301, USA.
+
+
+DIST_SUBDIRS = \
+       linux
 
 SUBDIRS = $(OS_DIR)
 
@@ -7,19 +31,16 @@ AM_CCASFLAGS = $(AM_CPPFLAGS)
 
 LIBS =
 
-#BUILT_SOURCES = offsets.h
-
-CLEANFILES = offsets.h
-
 noinst_HEADERS = \
-        arch.h \
-        machine-instr.h
+       arch.h \
+       md-atomic.hpp
 
-noinst_LTLIBRARIES = libarch.la
+noinst_LTLIBRARIES = \
+       libarch.la
 
 if ENABLE_DISASSEMBLER
 DISASS_SOURCES = \
-         disass.c
+       disass.c
 endif
 
 libarch_la_SOURCES = \
@@ -28,13 +49,24 @@ libarch_la_SOURCES = \
        codegen.h \
        $(DISASS_SOURCES) \
        emit.c \
+       emit.h \
+       patcher.c \
+       \
+       md-stubs.hpp \
+       md-trap.h \
        md.c \
-       patcher.c
-                                                      
+       md.h
+
 libarch_la_LIBADD = \
        $(OS_DIR)/libmd.la
-       $(srcdir)/asmpart.S: $(top_builddir)/config.h offsets.h
 
-#offsets.h: $(top_builddir)/src/vm/jit/tools/genoffsets $(top_builddir)/config.h
-#      $(top_builddir)/src/vm/jit/tools/genoffsets > offsets.h
+$(srcdir)/asmpart.S: $(top_builddir)/config.h
+
 
+## Local variables:
+## mode: Makefile
+## indent-tabs-mode: t
+## c-basic-offset: 4
+## tab-width: 8
+## compile-command: "automake --add-missing"
+## End: