* src/vm/jit/i386/asmpart.S: Made position independent.
[cacao.git] / src / vm / jit / i386 / Makefile.am
index a8b915c25511bf1ed85734f95b9e6712c107ae73..9a596a47eda6e3e952241e0a5aacd74a05578c95 100644 (file)
@@ -1,41 +1,76 @@
-## Process this file with automake to produce Makefile.in
+## src/vm/jit/i386/Makefile.am
+##
+## Copyright (C) 1996-2005, 2006, 2007, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
+##
+## This file is part of CACAO.
+##
+## This program is free software; you can redistribute it and/or
+## modify it under the terms of the GNU General Public License as
+## published by the Free Software Foundation; either version 2, or (at
+## your option) any later version.
+##
+## This program is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+## General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+## 02110-1301, USA.
 
-# $Id: Makefile.am 1254 2004-06-30 20:38:42Z twisti $
 
+DIST_SUBDIRS = \
+       cygwin \
+       darwin \
+       freebsd \
+       linux \
+       solaris
 
-INCLUDES = -I$(top_srcdir)
+SUBDIRS = $(OS_DIR)
 
-EXTRA_DIST = \
+AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_builddir) -I$(top_builddir)/src -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR)/$(OS_DIR)
+AM_CCASFLAGS = $(AM_CPPFLAGS)
+
+if ENABLE_PIC_ASM
+AM_CCASFLAGS += -DENABLE_PIC_ASM
+endif
+
+LIBS =
+
+noinst_HEADERS = \
+       arch.h \
+       md-atomic.hpp
+
+noinst_LTLIBRARIES = \
+       libarch.la
+
+if ENABLE_DISASSEMBLER
+DISASS_SOURCES = \
+       disass.c
+endif
+
+libarch_la_SOURCES = \
        asmpart.S \
-       bfd.h \
        codegen.c \
        codegen.h \
-       dis-asm.h \
-       disass.c \
-       disass.h \
-       emitfuncs.c \
-       emitfuncs.h \
-       machine-instr.h \
-       native-math.h \
-       types.h
-
-noinst_LIBRARIES = libarch.a
-
-libarch_a_SOURCES = \
-       asmpart.S \
-       codegen.c \
-       dis-buf.c \
-       disass.c \
-       emitfuncs.c \
-       i386-dis.c
-
-asmpart.o: asmpart.S $(top_srcdir)/config.h offsets.h
-       $(COMPILE) -c $<
-
-#offsets.h: $(top_srcdir)/genoffsets $(top_srcdir)/config.h
-offsets.h: $(top_srcdir)/config.h $(top_srcdir)/global.h $(top_srcdir)/threads/thread.h
-       $(COMPILE) -o $(top_srcdir)/genoffsets $(top_srcdir)/genoffsets.c
-       $(top_srcdir)/genoffsets > offsets.h
+       $(DISASS_SOURCES) \
+       emit.c \
+       emit.h \
+       patcher.c \
+       \
+       md-abi.c \
+       md-abi.h \
+       md-stubs.hpp \
+       md-trap.h \
+       md.c \
+       md.h
+
+libarch_la_LIBADD = \
+       $(OS_DIR)/libmd.la
+
+$(srcdir)/asmpart.S: $(top_builddir)/config.h
 
 
 ## Local variables: