* src/vm/jit/i386/asmpart.S: Made position independent.
[cacao.git] / src / vm / jit / i386 / Makefile.am
index 89b90c006fbaef38a5c5003a38cb32ab48e57729..9a596a47eda6e3e952241e0a5aacd74a05578c95 100644 (file)
@@ -1,9 +1,7 @@
 ## src/vm/jit/i386/Makefile.am
 ##
-## Copyright (C) 1996-2005, 2006 R. Grafl, A. Krall, C. Kruegel,
-## C. Oates, R. Obermaisser, M. Platter, M. Probst, S. Ring,
-## E. Steiner, C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich,
-## J. Wenninger, Institut f. Computersprachen - TU Wien
+## Copyright (C) 1996-2005, 2006, 2007, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
 ##
 ## This file is part of CACAO.
 ##
 ## along with this program; if not, write to the Free Software
 ## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
 ## 02110-1301, USA.
-##
-## Contact: cacao@cacaojvm.org
-##
-## Authors: Christian Thalinger
-##
-## Changes:
-##
-## $Id: Makefile.am 5300 2006-09-05 10:15:55Z twisti $
 
-## Process this file with automake to produce Makefile.in
 
 DIST_SUBDIRS = \
+       cygwin \
        darwin \
        freebsd \
-       linux
+       linux \
+       solaris
 
 SUBDIRS = $(OS_DIR)
 
 AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_builddir) -I$(top_builddir)/src -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR)/$(OS_DIR)
 AM_CCASFLAGS = $(AM_CPPFLAGS)
 
-LIBS =
-
-BUILT_SOURCES = offsets.h
+if ENABLE_PIC_ASM
+AM_CCASFLAGS += -DENABLE_PIC_ASM
+endif
 
-CLEANFILES = offsets.h
+LIBS =
 
 noinst_HEADERS = \
        arch.h \
-       machine-instr.h
+       md-atomic.hpp
 
 noinst_LTLIBRARIES = \
        libarch.la
@@ -66,20 +57,20 @@ libarch_la_SOURCES = \
        codegen.h \
        $(DISASS_SOURCES) \
        emit.c \
-       md-emit.h \
-       md.c \
+       emit.h \
        patcher.c \
        \
        md-abi.c \
-       md-abi.h
+       md-abi.h \
+       md-stubs.hpp \
+       md-trap.h \
+       md.c \
+       md.h
 
 libarch_la_LIBADD = \
        $(OS_DIR)/libmd.la
 
-$(srcdir)/asmpart.S: $(top_builddir)/config.h offsets.h
-
-offsets.h: $(top_builddir)/src/vm/jit/tools/genoffsets $(top_builddir)/config.h
-       $(top_builddir)/src/vm/jit/tools/genoffsets > offsets.h
+$(srcdir)/asmpart.S: $(top_builddir)/config.h
 
 
 ## Local variables: