* src/vm/jit/i386/asmpart.S: Made position independent.
[cacao.git] / src / vm / jit / i386 / Makefile.am
index 5b0f60193bae808a6cbd1605b0a897a8e3901fd2..9a596a47eda6e3e952241e0a5aacd74a05578c95 100644 (file)
@@ -1,9 +1,7 @@
 ## src/vm/jit/i386/Makefile.am
 ##
-## Copyright (C) 1996-2005 R. Grafl, A. Krall, C. Kruegel, C. Oates,
-## R. Obermaisser, M. Platter, M. Probst, S. Ring, E. Steiner,
-## C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich, J. Wenninger,
-## Institut f. Computersprachen - TU Wien
+## Copyright (C) 1996-2005, 2006, 2007, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
 ##
 ## This file is part of CACAO.
 ##
 ##
 ## You should have received a copy of the GNU General Public License
 ## along with this program; if not, write to the Free Software
-## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
-## 02111-1307, USA.
-##
-## Contact: cacao@complang.tuwien.ac.at
-##
-## Authors: Christian Thalinger
-##
-## Changes:
-##
-## $Id: Makefile.am 2605 2005-06-08 14:41:35Z christian $
+## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+## 02110-1301, USA.
+
+
+DIST_SUBDIRS = \
+       cygwin \
+       darwin \
+       freebsd \
+       linux \
+       solaris
 
-## Process this file with automake to produce Makefile.in
+SUBDIRS = $(OS_DIR)
 
-INCLUDES = -I$(top_srcdir)/src -I$(top_builddir) -I$(top_builddir)/src
+AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_builddir) -I$(top_builddir)/src -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR)/$(OS_DIR)
+AM_CCASFLAGS = $(AM_CPPFLAGS)
 
-AM_CCASFLAGS = $(INCLUDES)
+if ENABLE_PIC_ASM
+AM_CCASFLAGS += -DENABLE_PIC_ASM
+endif
 
-CLEANFILES = offsets.h
+LIBS =
 
 noinst_HEADERS = \
        arch.h \
-       machine-instr.h \
-       md-abi.h \
-       types.h
+       md-atomic.hpp
+
+noinst_LTLIBRARIES = \
+       libarch.la
 
-noinst_LTLIBRARIES = libarch.la
+if ENABLE_DISASSEMBLER
+DISASS_SOURCES = \
+       disass.c
+endif
 
 libarch_la_SOURCES = \
-       ansidecl.h \
-       asmoffsets.h \
        asmpart.S \
-       bfd.h \
        codegen.c \
        codegen.h \
-       dis-buf.c \
-       dis-asm.h \
-       disass.c \
-       disass.h \
-       emitfuncs.c \
-       emitfuncs.h \
-       i386-dis.c \
-       md-abi.inc \
-       md-abi.c \
+       $(DISASS_SOURCES) \
+       emit.c \
+       emit.h \
        patcher.c \
-       symcat.h
+       \
+       md-abi.c \
+       md-abi.h \
+       md-stubs.hpp \
+       md-trap.h \
+       md.c \
+       md.h
 
-$(srcdir)/asmpart.S: $(top_builddir)/config.h offsets.h
+libarch_la_LIBADD = \
+       $(OS_DIR)/libmd.la
 
-offsets.h: $(top_builddir)/src/vm/jit/tools/genoffsets $(top_builddir)/config.h
-       $(top_builddir)/src/vm/jit/tools/genoffsets > offsets.h
+$(srcdir)/asmpart.S: $(top_builddir)/config.h
 
 
 ## Local variables: