- build/dist/install changes
[cacao.git] / src / vm / jit / Makefile.am
index 49b00bdd09e225bd3b6141a205c2a92bf1374afa..5d719c47b35d3da41c1e60a12adbcfdf06a2b97f 100644 (file)
@@ -1,6 +1,34 @@
-## Process this file with automake to produce Makefile.in
+## Copyright (C) 1996-2005 R. Grafl, A. Krall, C. Kruegel, C. Oates,
+## R. Obermaisser, M. Platter, M. Probst, S. Ring, E. Steiner,
+## C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich, J. Wenninger,
+## TU Wien
+##
+## This file is part of CACAO.
+##
+## This program is free software; you can redistribute it and/or
+## modify it under the terms of the GNU General Public License as
+## published by the Free Software Foundation; either version 2, or (at
+## your option) any later version.
+##
+## This program is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+## General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+## 02111-1307, USA.
+##
+## Contact: cacao@complang.tuwien.ac.at
+##
+## Authors: Christian Thalinger
+##
+## Changes:
+##
+## $Id: Makefile.am 1676 2004-12-03 16:52:15Z twisti $
 
-# $Id: Makefile.am 1621 2004-11-30 13:06:55Z twisti $
+## Process this file with automake to produce Makefile.in
 
 INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/vm/jit/@ARCH_DIR@
 
@@ -8,17 +36,24 @@ SUBDIRS = inline loop verify tools @ARCH_DIR@
 
 DIST_SUBDIRS = inline loop verify tools alpha i386 mips powerpc x86_64
 
+noinst_HEADERS = \
+       asmpart.h \
+       codegen.inc \
+       codegen.inc.h \
+       lsra.inc \
+       lsra.h \
+       reg.inc \
+       reg.h
+
 noinst_LIBRARIES = libjit.a
 
 libjit_a_SOURCES = \
        jit.c \
+       jit.h \
        parse.c \
-       stack.c
-
-libjit_a_LIBADD = \
-       inline/libinline.a \
-       loop/libloop.a \
-       verify/libverify.a
+       parse.h \
+       stack.c \
+       stack.h
 
 
 ## Local variables: