* configure.ac: Some maintenance for make dist.
[cacao.git] / src / vm / jit / Makefile.am
index c44f0129e57414a011bf69ab01d8158e4242651b..4570ed8d221e4969bb4856369bf760e7c9f06859 100644 (file)
@@ -103,16 +103,20 @@ REG_SOURCES = \
        reg.h
 
 REPLACE_SOURCES += \
-       replace.h
+       replace.hpp
 
 STACK_SOURCES = \
        stack.c \
        stack.h
+
+TRAP_SOURCES = \
+       trap.cpp \
+       trap.hpp
 endif
 
 if ENABLE_REPLACEMENT
 REPLACE_SOURCES += \
-       replace.c
+       replace.cpp
 endif
 
 if ENABLE_VERIFIER
@@ -123,6 +127,13 @@ VERIFIER_LIB = \
        verify/libverify.la
 endif
 
+if ENABLE_OPAGENT
+OPAGENT_SOURCES = \
+       oprofile-agent.cpp \
+       oprofile-agent.hpp
+
+endif
+
 if WITH_BINUTILS_DISASSEMBLER
 DISASS_SOURCES = disass-common.c
 endif
@@ -137,43 +148,49 @@ noinst_LTLIBRARIES = \
        libjit.la
 
 libjit_la_SOURCES = \
-       argument.c \
-       argument.h \
-       code.c \
-       code.h \
-       codegen-common.c \
-       codegen-common.h \
+       argument.cpp \
+       argument.hpp \
+       builtin.cpp \
+       builtin.hpp \
+       builtintable.inc \
+       code.cpp \
+       code.hpp \
+       codegen-common.cpp \
+       codegen-common.hpp \
        disass.h \
        $(DISASS_SOURCES) \
        dseg.c \
        dseg.h \
-       emit-common.c \
-       emit-common.h \
+       emit-common.cpp \
+       emit-common.hpp \
        exceptiontable.c \
        exceptiontable.h \
        executionstate.c \
        executionstate.h \
-       icmdtable.inc \
-       jit.c \
-       jit.h \
-       linenumbertable.c \
-       linenumbertable.h \
+       jit.cpp \
+       jit.hpp \
+       linenumbertable.cpp \
+       linenumbertable.hpp \
        methodtree.c \
        methodtree.h \
-       parse.c \
-       parse.h \
-       patcher-common.c \
-       patcher-common.h \
+       parse.cpp \
+       parse.hpp \
+       patcher-common.cpp \
+       patcher-common.hpp \
        $(RECOMPILE_SOURCES) \
        $(REG_SOURCES) \
        $(REPLACE_SOURCES) \
-       show.c \
-       show.h \
+       show.cpp \
+       show.hpp \
        $(STACK_SOURCES) \
-       stacktrace.c \
-       stacktrace.h \
-       trace.c \
-       trace.h
+       stacktrace.cpp \
+       stacktrace.hpp \
+       stubs.cpp \
+       stubs.hpp \
+       trace.cpp \
+       trace.hpp \
+       $(TRAP_SOURCES) \
+       $(OPAGENT_SOURCES)
 
 libjit_la_SOURCES += \
        cfg.c \
@@ -193,7 +210,8 @@ libjit_la_LIBADD = \
 
 if ENABLE_PYTHON
 libjit_la_SOURCES += \
-       python.c
+       python.c \
+       python.h
 AM_CPPFLAGS += \
        @PYTHON_CSPEC@
 LIBS += \