* configure.ac: Some maintenance for make dist.
[cacao.git] / src / vm / jit / Makefile.am
index ad7d6524ff33d87d6836d6161707a96fc9cd5c18..4570ed8d221e4969bb4856369bf760e7c9f06859 100644 (file)
@@ -110,8 +110,8 @@ STACK_SOURCES = \
        stack.h
 
 TRAP_SOURCES = \
-       trap.c \
-       trap.h
+       trap.cpp \
+       trap.hpp
 endif
 
 if ENABLE_REPLACEMENT
@@ -148,8 +148,8 @@ noinst_LTLIBRARIES = \
        libjit.la
 
 libjit_la_SOURCES = \
-       argument.c \
-       argument.h \
+       argument.cpp \
+       argument.hpp \
        builtin.cpp \
        builtin.hpp \
        builtintable.inc \
@@ -173,15 +173,15 @@ libjit_la_SOURCES = \
        linenumbertable.hpp \
        methodtree.c \
        methodtree.h \
-       parse.c \
-       parse.h \
+       parse.cpp \
+       parse.hpp \
        patcher-common.cpp \
        patcher-common.hpp \
        $(RECOMPILE_SOURCES) \
        $(REG_SOURCES) \
        $(REPLACE_SOURCES) \
-       show.c \
-       show.h \
+       show.cpp \
+       show.hpp \
        $(STACK_SOURCES) \
        stacktrace.cpp \
        stacktrace.hpp \
@@ -210,7 +210,8 @@ libjit_la_LIBADD = \
 
 if ENABLE_PYTHON
 libjit_la_SOURCES += \
-       python.c
+       python.c \
+       python.h
 AM_CPPFLAGS += \
        @PYTHON_CSPEC@
 LIBS += \