* configure.ac: Some maintenance for make dist.
[cacao.git] / src / vm / jit / Makefile.am
index 60aa36c63c4f109c2725b438389ccfbaee5b8a55..4570ed8d221e4969bb4856369bf760e7c9f06859 100644 (file)
@@ -1,9 +1,7 @@
 ## src/vm/jit/Makefile.am
 ##
-## Copyright (C) 1996-2005, 2006 R. Grafl, A. Krall, C. Kruegel,
-## C. Oates, R. Obermaisser, M. Platter, M. Probst, S. Ring,
-## E. Steiner, C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich,
-## J. Wenninger, Institut f. Computersprachen - TU Wien
+## Copyright (C) 1996-2005, 2006, 2007, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
 ##
 ## This file is part of CACAO.
 ##
 ## along with this program; if not, write to the Free Software
 ## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
 ## 02110-1301, USA.
-##
-## Contact: cacao@cacaojvm.org
-##
-## Authors: Christian Thalinger
-##
-## Changes: Edwin Steiner
-##
-## $Id: Makefile.am 5234 2006-08-14 17:50:12Z christian $
 
-## Process this file with automake to produce Makefile.in
 
-AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR) -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR)/$(OS_DIR)
+AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR) -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR)/$(OS_DIR) -I$(top_builddir)/src -I$(top_srcdir)/contrib/vmlog
 
 LIBS =
 
 DIST_SUBDIRS = \
        allocator \
-       ifconv \
        inline \
+       ir \
        loop \
-       profile \
+       optimizing \
        schedule \
-       tools \
        verify \
        \
        intrp \
        alpha \
+       arm \
        i386 \
+       m68k \
        mips \
+       parisc \
        powerpc \
-       x86_64 \
-       sparc64
+       powerpc64 \
+       s390 \
+       sparc64 \
+       x86_64
 
 SUBDIRS = \
-       allocator \
-       tools \
-       verify
+       ir \
+       optimizing \
+       $(ARCH_DIR)
+
+ARCH_LIB = \
+       $(ARCH_DIR)/libarch.la
 
 if ENABLE_JIT
-SUBDIRS += $(ARCH_DIR)
-ARCH_LIB = $(ARCH_DIR)/libarch.la
+SUBDIRS += \
+       allocator
+
+OPTIMIZING_LIB = \
+       optimizing/liboptimizing.la
 endif
 
 if ENABLE_INTRP
-SUBDIRS += intrp
-INTRP_LIB = intrp/libintrp.la
-endif
+SUBDIRS += \
+       intrp
 
-if ENABLE_IFCONV
-SUBDIRS += ifconv
-IFCONV_LIB = ifconv/libifconv.la
+INTRP_LIB = \
+       intrp/libintrp.la
 endif
 
 if ENABLE_INLINING
-SUBDIRS += inline
-INLINE_LIB = inline/libinline.la
+SUBDIRS += \
+       inline
+
+INLINE_LIB = \
+       inline/libinline.la
 endif
 
 if ENABLE_LOOP
-SUBDIRS += loop
-LOOP_LIB = loop/libloop.la
+SUBDIRS += \
+       loop
+
+LOOP_LIB = \
+       loop/libloop.la
 endif
 
-if ENABLE_PROFILING
-SUBDIRS += profile
-PROFILE_LIB = profile/libprofile.la
+if USE_SCHEDULER
+SUBDIRS += \
+       schedule
+
+SCHEDULE_LIB = \
+       schedule/libschedule.la
 endif
 
-if ENABLE_THREADS
-RECOMPILE_SOURCES = \
-       recompile.c \
-       recompile.h
+REPLACE_SOURCES =
+
+if ENABLE_JIT
+REG_SOURCES = \
+       reg.c \
+       reg.h
+
+REPLACE_SOURCES += \
+       replace.hpp
+
+STACK_SOURCES = \
+       stack.c \
+       stack.h
+
+TRAP_SOURCES = \
+       trap.cpp \
+       trap.hpp
 endif
 
-if USE_SCHEDULER
-SUBDIRS += schedule
-SCHEDULE_LIB = schedule/libschedule.la
+if ENABLE_REPLACEMENT
+REPLACE_SOURCES += \
+       replace.cpp
 endif
 
-if ENABLE_SSA
-SUBDIRS += optimizing
-OPTIMIZING_LIB = optimizing/liboptimizing.la
+if ENABLE_VERIFIER
+SUBDIRS += \
+       verify
+
+VERIFIER_LIB = \
+       verify/libverify.la
+endif
+
+if ENABLE_OPAGENT
+OPAGENT_SOURCES = \
+       oprofile-agent.cpp \
+       oprofile-agent.hpp
+
 endif
 
 if WITH_BINUTILS_DISASSEMBLER
 DISASS_SOURCES = disass-common.c
-else
-DISASS_SOURCES =
 endif
 
 noinst_HEADERS = \
        abi.h \
        abi-asm.h \
        asmpart.h \
-       emit.h \
-       methodheader.h \
-       patcher.h 
+       methodheader.h
 
-noinst_LTLIBRARIES = libjit.la
+noinst_LTLIBRARIES = \
+       libjit.la
 
 libjit_la_SOURCES = \
-       code.c \
-       code.h \
-       codegen-common.c \
-       codegen-common.h \
+       argument.cpp \
+       argument.hpp \
+       builtin.cpp \
+       builtin.hpp \
+       builtintable.inc \
+       code.cpp \
+       code.hpp \
+       codegen-common.cpp \
+       codegen-common.hpp \
        disass.h \
        $(DISASS_SOURCES) \
        dseg.c \
        dseg.h \
-       jit.c \
-       jit.h \
-       parse.c \
-       parse.h \
-       reg.c \
-       reg.h \
+       emit-common.cpp \
+       emit-common.hpp \
+       exceptiontable.c \
+       exceptiontable.h \
+       executionstate.c \
+       executionstate.h \
+       jit.cpp \
+       jit.hpp \
+       linenumbertable.cpp \
+       linenumbertable.hpp \
+       methodtree.c \
+       methodtree.h \
+       parse.cpp \
+       parse.hpp \
+       patcher-common.cpp \
+       patcher-common.hpp \
        $(RECOMPILE_SOURCES) \
-       replace.c \
-       replace.h \
-       show.c \
-       show.h \
-       stack.c \
-       stack.h \
-       stacktrace.c \
-       stacktrace.h
+       $(REG_SOURCES) \
+       $(REPLACE_SOURCES) \
+       show.cpp \
+       show.hpp \
+       $(STACK_SOURCES) \
+       stacktrace.cpp \
+       stacktrace.hpp \
+       stubs.cpp \
+       stubs.hpp \
+       trace.cpp \
+       trace.hpp \
+       $(TRAP_SOURCES) \
+       $(OPAGENT_SOURCES)
 
 libjit_la_SOURCES += \
        cfg.c \
-       cfg.h \
-       reorder.c \
-       reorder.h
+       cfg.h
 
 libjit_la_LIBADD = \
        allocator/liballocator.la \
-       verify/libverify.la \
-       $(ALLOCATOR_LIB) \
-       $(IFCONV_LIB) \
        $(INLINE_LIB) \
+       ir/libir.la \
        $(LOOP_LIB) \
        $(OPTIMIZING_LIB) \
        $(PROFILE_LIB) \
        $(SCHEDULE_LIB) \
+       $(VERIFIER_LIB) \
        $(INTRP_LIB) \
        $(ARCH_LIB)
 
+if ENABLE_PYTHON
+libjit_la_SOURCES += \
+       python.c \
+       python.h
+AM_CPPFLAGS += \
+       @PYTHON_CSPEC@
+LIBS += \
+       @PYTHON_LSPEC@
+endif
+
 
 ## Local variables:
 ## mode: Makefile