* configure.ac: Some maintenance for make dist.
[cacao.git] / src / vm / jit / Makefile.am
index 2ea63caecb5072ef4dc46e94ed4fac63a2e5b3d9..4570ed8d221e4969bb4856369bf760e7c9f06859 100644 (file)
@@ -1,9 +1,7 @@
 ## src/vm/jit/Makefile.am
 ##
-## Copyright (C) 1996-2005, 2006, 2007 R. Grafl, A. Krall, C. Kruegel,
-## C. Oates, R. Obermaisser, M. Platter, M. Probst, S. Ring,
-## E. Steiner, C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich,
-## J. Wenninger, Institut f. Computersprachen - TU Wien
+## Copyright (C) 1996-2005, 2006, 2007, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
 ##
 ## This file is part of CACAO.
 ##
 ## along with this program; if not, write to the Free Software
 ## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
 ## 02110-1301, USA.
-##
-## $Id: Makefile.am 8304 2007-08-14 19:57:20Z pm $
 
-## Process this file with automake to produce Makefile.in
 
 AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR) -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR)/$(OS_DIR) -I$(top_builddir)/src -I$(top_srcdir)/contrib/vmlog
 
@@ -33,6 +28,7 @@ LIBS =
 DIST_SUBDIRS = \
        allocator \
        inline \
+       ir \
        loop \
        optimizing \
        schedule \
@@ -52,6 +48,7 @@ DIST_SUBDIRS = \
        x86_64
 
 SUBDIRS = \
+       ir \
        optimizing \
        $(ARCH_DIR)
 
@@ -106,16 +103,20 @@ REG_SOURCES = \
        reg.h
 
 REPLACE_SOURCES += \
-       replace.h
+       replace.hpp
 
 STACK_SOURCES = \
        stack.c \
        stack.h
+
+TRAP_SOURCES = \
+       trap.cpp \
+       trap.hpp
 endif
 
 if ENABLE_REPLACEMENT
 REPLACE_SOURCES += \
-       replace.c
+       replace.cpp
 endif
 
 if ENABLE_VERIFIER
@@ -126,6 +127,13 @@ VERIFIER_LIB = \
        verify/libverify.la
 endif
 
+if ENABLE_OPAGENT
+OPAGENT_SOURCES = \
+       oprofile-agent.cpp \
+       oprofile-agent.hpp
+
+endif
+
 if WITH_BINUTILS_DISASSEMBLER
 DISASS_SOURCES = disass-common.c
 endif
@@ -134,41 +142,55 @@ noinst_HEADERS = \
        abi.h \
        abi-asm.h \
        asmpart.h \
-       md.h \
-       methodheader.h \
-       patcher.h 
+       methodheader.h
 
 noinst_LTLIBRARIES = \
        libjit.la
 
 libjit_la_SOURCES = \
-       code.c \
-       code.h \
-       codegen-common.c \
-       codegen-common.h \
+       argument.cpp \
+       argument.hpp \
+       builtin.cpp \
+       builtin.hpp \
+       builtintable.inc \
+       code.cpp \
+       code.hpp \
+       codegen-common.cpp \
+       codegen-common.hpp \
        disass.h \
        $(DISASS_SOURCES) \
        dseg.c \
        dseg.h \
-       emit-common.c \
-       emit-common.h \
-       icmdtable.inc \
-       jit.c \
-       jit.h \
-       parse.c \
-       parse.h \
-       patcher-common.c \
-       patcher-common.h \
+       emit-common.cpp \
+       emit-common.hpp \
+       exceptiontable.c \
+       exceptiontable.h \
+       executionstate.c \
+       executionstate.h \
+       jit.cpp \
+       jit.hpp \
+       linenumbertable.cpp \
+       linenumbertable.hpp \
+       methodtree.c \
+       methodtree.h \
+       parse.cpp \
+       parse.hpp \
+       patcher-common.cpp \
+       patcher-common.hpp \
        $(RECOMPILE_SOURCES) \
        $(REG_SOURCES) \
        $(REPLACE_SOURCES) \
-       show.c \
-       show.h \
+       show.cpp \
+       show.hpp \
        $(STACK_SOURCES) \
-       stacktrace.c \
-       stacktrace.h \
-       trace.c \
-       trace.h
+       stacktrace.cpp \
+       stacktrace.hpp \
+       stubs.cpp \
+       stubs.hpp \
+       trace.cpp \
+       trace.hpp \
+       $(TRAP_SOURCES) \
+       $(OPAGENT_SOURCES)
 
 libjit_la_SOURCES += \
        cfg.c \
@@ -176,8 +198,8 @@ libjit_la_SOURCES += \
 
 libjit_la_LIBADD = \
        allocator/liballocator.la \
-       $(ALLOCATOR_LIB) \
        $(INLINE_LIB) \
+       ir/libir.la \
        $(LOOP_LIB) \
        $(OPTIMIZING_LIB) \
        $(PROFILE_LIB) \
@@ -186,6 +208,16 @@ libjit_la_LIBADD = \
        $(INTRP_LIB) \
        $(ARCH_LIB)
 
+if ENABLE_PYTHON
+libjit_la_SOURCES += \
+       python.c \
+       python.h
+AM_CPPFLAGS += \
+       @PYTHON_CSPEC@
+LIBS += \
+       @PYTHON_LSPEC@
+endif
+
 
 ## Local variables:
 ## mode: Makefile