* src/vm/classcache.cpp,
[cacao.git] / src / vm / Makefile.am
index de4ea00bdf8c3ba709d16169d05806045a9b99ae..829fed607d0331a7b25074685fc27001f03cb8b7 100644 (file)
@@ -65,8 +65,8 @@ endif
 
 if ENABLE_ZLIB
 ZLIB_SOURCES = \
-       zip.c \
-       zip.h
+       zip.cpp \
+       zip.hpp
 endif
 
 noinst_HEADERS = \
@@ -85,8 +85,8 @@ libvm_la_SOURCES = \
        $(ASSERTION_SOURCES) \
        class.cpp \
        class.hpp \
-       classcache.c \
-       classcache.h \
+       classcache.cpp \
+       classcache.hpp \
        $(CYCLES_STATS_SOURCES) \
        descriptor.c \
        descriptor.h \
@@ -106,8 +106,8 @@ libvm_la_SOURCES = \
        linker.h \
        loader.cpp \
        loader.hpp \
-       method.c \
-       method.h \
+       method.cpp \
+       method.hpp \
        options.c \
        options.h \
        os.cpp \