PR156: Preparation
[cacao.git] / src / vm / Makefile.am
index cd56a115fff690fba2e7c554d365d0de759f02d9..2d4f2c48dd93f03f2562f6e170c788e287ac0a35 100644 (file)
@@ -29,8 +29,8 @@ SUBDIRS = jit
 
 if ENABLE_ASSERTION
 ASSERTION_SOURCES = \
-       assertion.c \
-       assertion.h
+       assertion.cpp \
+       assertion.hpp
 endif
 
 if ENABLE_CYCLES_STATS
@@ -39,6 +39,36 @@ CYCLES_STATS_SOURCES = \
        cycles-stats.h
 endif
 
+if ENABLE_JAVASE
+if ENABLE_ANNOTATIONS
+ANNOTATION_SOURCES = \
+       annotation.cpp \
+       annotation.hpp
+endif
+
+STACKMAP_SOURCES = \
+       stackmap.c \
+       stackmap.h
+endif
+
+if ENABLE_RT_TIMING
+RT_TIMING_SOURCES = \
+       rt-timing.c \
+       rt-timing.h
+endif
+
+if ENABLE_STATISTICS
+STATISTICS_SOURCES = \
+       statistics.c \
+       statistics.h
+endif
+
+if ENABLE_ZLIB
+ZLIB_SOURCES = \
+       zip.cpp \
+       zip.hpp
+endif
+
 noinst_HEADERS = \
        global.h \
        types.h
@@ -47,36 +77,68 @@ noinst_LTLIBRARIES = \
        libvm.la
 
 libvm_la_SOURCES = \
+       access.cpp \
+       access.hpp \
+       $(ANNOTATION_SOURCES) \
+       array.cpp \
+       array.hpp \
        $(ASSERTION_SOURCES) \
-       access.c \
-       access.h \
-       array.c \
-       array.h \
-       builtin.c \
-       builtin.h \
-       builtintable.inc \
+       breakpoint.hpp \
+       class.cpp \
+       class.hpp \
+       classcache.cpp \
+       classcache.hpp \
        $(CYCLES_STATS_SOURCES) \
-       exceptions.c \
-       exceptions.h \
-       finalizer.c \
-       finalizer.h \
-       initialize.c \
-       initialize.h \
-       jit_interface.h \
+       descriptor.cpp \
+       descriptor.hpp \
+       exceptions.cpp \
+       exceptions.hpp \
+       field.cpp \
+       field.hpp \
+       finalizer.cpp \
+       finalizer.hpp \
+       globals.cpp \
+       globals.hpp \
+       hook.cpp \
+       hook.hpp \
+       initialize.cpp \
+       initialize.hpp \
+       javaobjects.cpp \
+       javaobjects.hpp \
+       linker.cpp \
+       linker.hpp \
+       loader.cpp \
+       loader.hpp \
+       method.cpp \
+       method.hpp \
+       options.c \
+       options.h \
+       os.cpp \
+       os.hpp \
        package.cpp \
        package.hpp \
-       primitive.c \
-       primitive.h \
-       properties.c \
-       properties.h \
-       resolve.c \
-       resolve.h \
-       signal.c \
-       signallocal.h \
-       string.c \
-       stringlocal.h \
-       vm.c \
-       vm.h
+       primitive.cpp \
+       primitive.hpp \
+       properties.cpp \
+       properties.hpp \
+       references.h \
+       resolve.cpp \
+       resolve.hpp \
+       $(RT_TIMING_SOURCES) \
+       signal.cpp \
+       signallocal.hpp \
+       $(STACKMAP_SOURCES) \
+       $(STATISTICS_SOURCES) \
+       string.cpp \
+       string.hpp \
+       suck.cpp \
+       suck.hpp \
+       utf8.c \
+       utf8.h \
+       vftbl.hpp \
+       vm.cpp \
+       vm.hpp \
+       $(ZLIB_SOURCES)
 
 libvm_la_LIBADD = \
        jit/libjit.la