PR156: Preparation
[cacao.git] / src / vm / Makefile.am
index 97b04c69acbdfd088c35d339a0e8f9454803b011..2d4f2c48dd93f03f2562f6e170c788e287ac0a35 100644 (file)
@@ -29,8 +29,8 @@ SUBDIRS = jit
 
 if ENABLE_ASSERTION
 ASSERTION_SOURCES = \
-       assertion.c \
-       assertion.h
+       assertion.cpp \
+       assertion.hpp
 endif
 
 if ENABLE_CYCLES_STATS
@@ -42,8 +42,8 @@ endif
 if ENABLE_JAVASE
 if ENABLE_ANNOTATIONS
 ANNOTATION_SOURCES = \
-       annotation.c \
-       annotation.h
+       annotation.cpp \
+       annotation.hpp
 endif
 
 STACKMAP_SOURCES = \
@@ -65,8 +65,8 @@ endif
 
 if ENABLE_ZLIB
 ZLIB_SOURCES = \
-       zip.c \
-       zip.h
+       zip.cpp \
+       zip.hpp
 endif
 
 noinst_HEADERS = \
@@ -77,38 +77,40 @@ noinst_LTLIBRARIES = \
        libvm.la
 
 libvm_la_SOURCES = \
-       access.c \
-       access.h \
+       access.cpp \
+       access.hpp \
        $(ANNOTATION_SOURCES) \
-       array.c \
-       array.h \
+       array.cpp \
+       array.hpp \
        $(ASSERTION_SOURCES) \
-       class.c \
-       class.h \
-       classcache.c \
-       classcache.h \
+       breakpoint.hpp \
+       class.cpp \
+       class.hpp \
+       classcache.cpp \
+       classcache.hpp \
        $(CYCLES_STATS_SOURCES) \
-       descriptor.c \
-       descriptor.h \
+       descriptor.cpp \
+       descriptor.hpp \
        exceptions.cpp \
        exceptions.hpp \
        field.cpp \
        field.hpp \
-       finalizer.c \
-       finalizer.h \
+       finalizer.cpp \
+       finalizer.hpp \
        globals.cpp \
        globals.hpp \
-       initialize.c \
-       initialize.h \
+       hook.cpp \
+       hook.hpp \
+       initialize.cpp \
+       initialize.hpp \
        javaobjects.cpp \
        javaobjects.hpp \
-       jit_interface.h \
-       linker.c \
-       linker.h \
+       linker.cpp \
+       linker.hpp \
        loader.cpp \
        loader.hpp \
-       method.c \
-       method.h \
+       method.cpp \
+       method.hpp \
        options.c \
        options.h \
        os.cpp \
@@ -120,11 +122,11 @@ libvm_la_SOURCES = \
        properties.cpp \
        properties.hpp \
        references.h \
-       resolve.c \
-       resolve.h \
+       resolve.cpp \
+       resolve.hpp \
        $(RT_TIMING_SOURCES) \
-       signal.c \
-       signallocal.h \
+       signal.cpp \
+       signallocal.hpp \
        $(STACKMAP_SOURCES) \
        $(STATISTICS_SOURCES) \
        string.cpp \
@@ -133,6 +135,7 @@ libvm_la_SOURCES = \
        suck.hpp \
        utf8.c \
        utf8.h \
+       vftbl.hpp \
        vm.cpp \
        vm.hpp \
        $(ZLIB_SOURCES)