PR156: Preparation
[cacao.git] / src / vm / Makefile.am
index 72bded3344c5e9fb72acb5cd69f415638a39831f..2d4f2c48dd93f03f2562f6e170c788e287ac0a35 100644 (file)
@@ -1,9 +1,7 @@
 ## src/vm/Makefile.am
 ##
-## Copyright (C) 1996-2005 R. Grafl, A. Krall, C. Kruegel, C. Oates,
-## R. Obermaisser, M. Platter, M. Probst, S. Ring, E. Steiner,
-## C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich, J. Wenninger,
-## Institut f. Computersprachen - TU Wien
+## Copyright (C) 1996-2005, 2006, 2007, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
 ##
 ## This file is part of CACAO.
 ##
 ##
 ## You should have received a copy of the GNU General Public License
 ## along with this program; if not, write to the Free Software
-## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
-## 02111-1307, USA.
-##
-## Contact: cacao@complang.tuwien.ac.at
-##
-## Authors: Christian Thalinger
-##
-## Changes:
-##
-## $Id: Makefile.am 2795 2005-06-23 09:34:51Z twisti $
+## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+## 02110-1301, USA.
+
 
-## Process this file with automake to produce Makefile.in
+AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR) -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR)/$(OS_DIR) -I$(top_builddir)/src -I$(top_srcdir)/contrib/vmlog -I$(top_srcdir)/src/native
 
-INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/vm/jit/@ARCH_DIR@ -I$(top_srcdir)/src/vm/jit/@ARCH_DIR@/@OS_DIR@
+LIBS =
 
 SUBDIRS = jit
 
-if STATISTICS
-STATISTICS_OBJ = \
+if ENABLE_ASSERTION
+ASSERTION_SOURCES = \
+       assertion.cpp \
+       assertion.hpp
+endif
+
+if ENABLE_CYCLES_STATS
+CYCLES_STATS_SOURCES = \
+       cycles-stats.c \
+       cycles-stats.h
+endif
+
+if ENABLE_JAVASE
+if ENABLE_ANNOTATIONS
+ANNOTATION_SOURCES = \
+       annotation.cpp \
+       annotation.hpp
+endif
+
+STACKMAP_SOURCES = \
+       stackmap.c \
+       stackmap.h
+endif
+
+if ENABLE_RT_TIMING
+RT_TIMING_SOURCES = \
+       rt-timing.c \
+       rt-timing.h
+endif
+
+if ENABLE_STATISTICS
+STATISTICS_SOURCES = \
        statistics.c \
        statistics.h
 endif
 
-if USE_ZLIB
-ZLIB_OBJ = \
-       unzip.c \
-       unzip.h
+if ENABLE_ZLIB
+ZLIB_SOURCES = \
+       zip.cpp \
+       zip.hpp
 endif
 
-noinst_HEADERS = global.h
-
-noinst_LTLIBRARIES = libvmcore.la libvm.la
-
-libvmcore_la_SOURCES = \
-       access.c \
-       access.h \
-       builtin.c \
-       builtin.h \
-       builtintable.inc \
-       class.c \
-       class.h \
-       classcache.c \
-       classcache.h \
-       descriptor.c \
-       descriptor.h \
-       field.c \
-       field.h \
-       initialize.c \
-       initialize.h \
-       linker.c \
-       linker.h \
-       loader.c \
-       loader.h \
-       method.c \
-       method.h \
+noinst_HEADERS = \
+       global.h \
+       types.h
+
+noinst_LTLIBRARIES = \
+       libvm.la
+
+libvm_la_SOURCES = \
+       access.cpp \
+       access.hpp \
+       $(ANNOTATION_SOURCES) \
+       array.cpp \
+       array.hpp \
+       $(ASSERTION_SOURCES) \
+       breakpoint.hpp \
+       class.cpp \
+       class.hpp \
+       classcache.cpp \
+       classcache.hpp \
+       $(CYCLES_STATS_SOURCES) \
+       descriptor.cpp \
+       descriptor.hpp \
+       exceptions.cpp \
+       exceptions.hpp \
+       field.cpp \
+       field.hpp \
+       finalizer.cpp \
+       finalizer.hpp \
+       globals.cpp \
+       globals.hpp \
+       hook.cpp \
+       hook.hpp \
+       initialize.cpp \
+       initialize.hpp \
+       javaobjects.cpp \
+       javaobjects.hpp \
+       linker.cpp \
+       linker.hpp \
+       loader.cpp \
+       loader.hpp \
+       method.cpp \
+       method.hpp \
        options.c \
        options.h \
+       os.cpp \
+       os.hpp \
+       package.cpp \
+       package.hpp \
+       primitive.cpp \
+       primitive.hpp \
+       properties.cpp \
+       properties.hpp \
        references.h \
-       resolve.c \
-       resolve.h \
-       $(STATISTICS_OBJ) \
-       signal.c \
-       signallocal.h \
-       string.c \
-       string.h \
-       tables.c \
-       tables.h \
+       resolve.cpp \
+       resolve.hpp \
+       $(RT_TIMING_SOURCES) \
+       signal.cpp \
+       signallocal.hpp \
+       $(STACKMAP_SOURCES) \
+       $(STATISTICS_SOURCES) \
+       string.cpp \
+       string.hpp \
+       suck.cpp \
+       suck.hpp \
        utf8.c \
        utf8.h \
-       $(ZLIB_OBJ)
-
-libvm_la_SOURCES = \
-       exceptions.c \
-       exceptions.h
+       vftbl.hpp \
+       vm.cpp \
+       vm.hpp \
+       $(ZLIB_SOURCES)
 
 libvm_la_LIBADD = \
-       libvmcore.la \
        jit/libjit.la