PR156: Preparation
[cacao.git] / src / vm / Makefile.am
index 6a6e8d8c5a9acba79edad620b7713485e760c106..2d4f2c48dd93f03f2562f6e170c788e287ac0a35 100644 (file)
@@ -1,9 +1,7 @@
 ## src/vm/Makefile.am
 ##
-## Copyright (C) 1996-2005, 2006, 2007 R. Grafl, A. Krall, C. Kruegel,
-## C. Oates, R. Obermaisser, M. Platter, M. Probst, S. Ring,
-## E. Steiner, C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich,
-## J. Wenninger, Institut f. Computersprachen - TU Wien
+## Copyright (C) 1996-2005, 2006, 2007, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
 ##
 ## This file is part of CACAO.
 ##
 ## along with this program; if not, write to the Free Software
 ## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
 ## 02110-1301, USA.
-##
-## $Id: Makefile.am 8343 2007-08-17 21:39:32Z michi $
 
-## Process this file with automake to produce Makefile.in
 
 AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR) -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR)/$(OS_DIR) -I$(top_builddir)/src -I$(top_srcdir)/contrib/vmlog -I$(top_srcdir)/src/native
 
@@ -32,12 +27,48 @@ LIBS =
 
 SUBDIRS = jit
 
+if ENABLE_ASSERTION
+ASSERTION_SOURCES = \
+       assertion.cpp \
+       assertion.hpp
+endif
+
 if ENABLE_CYCLES_STATS
 CYCLES_STATS_SOURCES = \
        cycles-stats.c \
        cycles-stats.h
 endif
 
+if ENABLE_JAVASE
+if ENABLE_ANNOTATIONS
+ANNOTATION_SOURCES = \
+       annotation.cpp \
+       annotation.hpp
+endif
+
+STACKMAP_SOURCES = \
+       stackmap.c \
+       stackmap.h
+endif
+
+if ENABLE_RT_TIMING
+RT_TIMING_SOURCES = \
+       rt-timing.c \
+       rt-timing.h
+endif
+
+if ENABLE_STATISTICS
+STATISTICS_SOURCES = \
+       statistics.c \
+       statistics.h
+endif
+
+if ENABLE_ZLIB
+ZLIB_SOURCES = \
+       zip.cpp \
+       zip.hpp
+endif
+
 noinst_HEADERS = \
        global.h \
        types.h
@@ -46,33 +77,68 @@ noinst_LTLIBRARIES = \
        libvm.la
 
 libvm_la_SOURCES = \
-       access.c \
-       access.h \
-       array.c \
-       array.h \
-       builtin.c \
-       builtin.h \
-       builtintable.inc \
+       access.cpp \
+       access.hpp \
+       $(ANNOTATION_SOURCES) \
+       array.cpp \
+       array.hpp \
+       $(ASSERTION_SOURCES) \
+       breakpoint.hpp \
+       class.cpp \
+       class.hpp \
+       classcache.cpp \
+       classcache.hpp \
        $(CYCLES_STATS_SOURCES) \
-       exceptions.c \
-       exceptions.h \
-       finalizer.c \
-       finalizer.h \
-       initialize.c \
-       initialize.h \
-       jit_interface.h \
-       primitive.c \
-       primitive.h \
-       properties.c \
-       properties.h \
-       resolve.c \
-       resolve.h \
-       signal.c \
-       signallocal.h \
-       string.c \
-       stringlocal.h \
-       vm.c \
-       vm.h
+       descriptor.cpp \
+       descriptor.hpp \
+       exceptions.cpp \
+       exceptions.hpp \
+       field.cpp \
+       field.hpp \
+       finalizer.cpp \
+       finalizer.hpp \
+       globals.cpp \
+       globals.hpp \
+       hook.cpp \
+       hook.hpp \
+       initialize.cpp \
+       initialize.hpp \
+       javaobjects.cpp \
+       javaobjects.hpp \
+       linker.cpp \
+       linker.hpp \
+       loader.cpp \
+       loader.hpp \
+       method.cpp \
+       method.hpp \
+       options.c \
+       options.h \
+       os.cpp \
+       os.hpp \
+       package.cpp \
+       package.hpp \
+       primitive.cpp \
+       primitive.hpp \
+       properties.cpp \
+       properties.hpp \
+       references.h \
+       resolve.cpp \
+       resolve.hpp \
+       $(RT_TIMING_SOURCES) \
+       signal.cpp \
+       signallocal.hpp \
+       $(STACKMAP_SOURCES) \
+       $(STATISTICS_SOURCES) \
+       string.cpp \
+       string.hpp \
+       suck.cpp \
+       suck.hpp \
+       utf8.c \
+       utf8.h \
+       vftbl.hpp \
+       vm.cpp \
+       vm.hpp \
+       $(ZLIB_SOURCES)
 
 libvm_la_LIBADD = \
        jit/libjit.la