PR156: Preparation
[cacao.git] / src / vm / Makefile.am
index 4dd35b7777dffcaf8468de71eaf49b9965f24311..2d4f2c48dd93f03f2562f6e170c788e287ac0a35 100644 (file)
@@ -42,8 +42,8 @@ endif
 if ENABLE_JAVASE
 if ENABLE_ANNOTATIONS
 ANNOTATION_SOURCES = \
-       annotation.c \
-       annotation.h
+       annotation.cpp \
+       annotation.hpp
 endif
 
 STACKMAP_SOURCES = \
@@ -83,21 +83,24 @@ libvm_la_SOURCES = \
        array.cpp \
        array.hpp \
        $(ASSERTION_SOURCES) \
+       breakpoint.hpp \
        class.cpp \
        class.hpp \
        classcache.cpp \
        classcache.hpp \
        $(CYCLES_STATS_SOURCES) \
-       descriptor.c \
-       descriptor.h \
+       descriptor.cpp \
+       descriptor.hpp \
        exceptions.cpp \
        exceptions.hpp \
        field.cpp \
        field.hpp \
-       finalizer.c \
-       finalizer.h \
+       finalizer.cpp \
+       finalizer.hpp \
        globals.cpp \
        globals.hpp \
+       hook.cpp \
+       hook.hpp \
        initialize.cpp \
        initialize.hpp \
        javaobjects.cpp \
@@ -122,8 +125,8 @@ libvm_la_SOURCES = \
        resolve.cpp \
        resolve.hpp \
        $(RT_TIMING_SOURCES) \
-       signal.c \
-       signallocal.h \
+       signal.cpp \
+       signallocal.hpp \
        $(STACKMAP_SOURCES) \
        $(STATISTICS_SOURCES) \
        string.cpp \