* src/threads/posix/thread-posix.cpp, src/threads/thread.cpp,
[cacao.git] / src / threads / Makefile.am
index b6cf86dd5bdfc94439964c1c0c7c11cd74faf3aa..98e8200b3b05e8d660ef9dd5584d5f57ff423da4 100644 (file)
@@ -49,14 +49,25 @@ noinst_LTLIBRARIES = \
 
 if ENABLE_THREADS
 libthreads_la_SOURCES = \
-       critical.c \
-       critical.h \
-       lock-common.h \
-       mutex.h \
-       threadlist.c \
-       threadlist.h \
-       thread.c \
-       thread.h
+       atomic.cpp \
+       atomic.hpp \
+       condition.hpp \
+       lock.cpp \
+       lock.hpp \
+       lockword.cpp \
+       lockword.hpp \
+       removeme.cpp \
+       mutex.hpp \
+       threadlist.cpp \
+       threadlist.hpp \
+       thread-classpath.cpp \
+       thread-classpath.hpp \
+       thread-cldc11.cpp \
+       thread-cldc11.hpp \
+       thread-openjdk.cpp \
+       thread-openjdk.hpp \
+       thread.cpp \
+       thread.hpp
 else
 libthreads_la_SOURCES =
 endif