* src/threads/posix/thread-posix.cpp, src/threads/thread.cpp,
[cacao.git] / src / threads / Makefile.am
index 6ba1d51d8d0d3ed009def30961c466f31d5beb46..98e8200b3b05e8d660ef9dd5584d5f57ff423da4 100644 (file)
@@ -29,23 +29,48 @@ DIST_SUBDIRS = \
        none \
        posix
 
+if ENABLE_THREADS
 SUBDIRS = \
        posix
 
 THREAD_LIB = \
-       posix/libposix.la
+       posix/libthreadsposix.la
+else
+SUBDIRS = \
+       none
+
+THREAD_LIB = \
+       none/libthreadsnone.la
+endif
+
 
 noinst_LTLIBRARIES = \
        libthreads.la
 
+if ENABLE_THREADS
 libthreads_la_SOURCES = \
-       critical.c \
-       critical.h \
-       lock-common.h \
-       threadlist.c \
-       threadlist.h \
-       threads-common.c \
-       threads-common.h
+       atomic.cpp \
+       atomic.hpp \
+       condition.hpp \
+       lock.cpp \
+       lock.hpp \
+       lockword.cpp \
+       lockword.hpp \
+       removeme.cpp \
+       mutex.hpp \
+       threadlist.cpp \
+       threadlist.hpp \
+       thread-classpath.cpp \
+       thread-classpath.hpp \
+       thread-cldc11.cpp \
+       thread-cldc11.hpp \
+       thread-openjdk.cpp \
+       thread-openjdk.hpp \
+       thread.cpp \
+       thread.hpp
+else
+libthreads_la_SOURCES =
+endif
 
 libthreads_la_LIBADD = \
        $(THREAD_LIB)