* src/threads/posix/thread-posix.cpp, src/threads/thread.cpp,
[cacao.git] / src / threads / Makefile.am
index 68cdfd9ec4d5c5c5b8373aa33cc3a9fa55949196..98e8200b3b05e8d660ef9dd5584d5f57ff423da4 100644 (file)
@@ -52,11 +52,20 @@ libthreads_la_SOURCES = \
        atomic.cpp \
        atomic.hpp \
        condition.hpp \
-       lock-common.h \
+       lock.cpp \
+       lock.hpp \
+       lockword.cpp \
+       lockword.hpp \
        removeme.cpp \
        mutex.hpp \
-       threadlist.c \
-       threadlist.h \
+       threadlist.cpp \
+       threadlist.hpp \
+       thread-classpath.cpp \
+       thread-classpath.hpp \
+       thread-cldc11.cpp \
+       thread-cldc11.hpp \
+       thread-openjdk.cpp \
+       thread-openjdk.hpp \
        thread.cpp \
        thread.hpp
 else