* src/threads/posix/thread-posix.cpp, src/threads/thread.cpp,
[cacao.git] / src / threads / Makefile.am
index 39091bffa56c4d955df5908331a4dbb49d10c2e8..98e8200b3b05e8d660ef9dd5584d5f57ff423da4 100644 (file)
@@ -1,9 +1,7 @@
 ## src/threads/Makefile.am
 ##
-## Copyright (C) 1996-2005, 2006 R. Grafl, A. Krall, C. Kruegel,
-## C. Oates, R. Obermaisser, M. Platter, M. Probst, S. Ring,
-## E. Steiner, C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich,
-## J. Wenninger, Institut f. Computersprachen - TU Wien
+## Copyright (C) 1996-2005, 2006, 2007, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
 ##
 ## This file is part of CACAO.
 ##
 ## along with this program; if not, write to the Free Software
 ## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
 ## 02110-1301, USA.
-##
-## Contact: cacao@cacaojvm.org
-##
-## Authors: Christian Thalinger
-##
-## Changes:
-##
-## $Id: Makefile.am 5122 2006-07-12 21:33:30Z twisti $
 
-## Process this file with automake to produce Makefile.in
+
+AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR) -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR)/$(OS_DIR) -I$(top_builddir)/src
+
+LIB =
 
 DIST_SUBDIRS = \
-       native \
+       none \
+       posix
+
+if ENABLE_THREADS
+SUBDIRS = \
+       posix
+
+THREAD_LIB = \
+       posix/libthreadsposix.la
+else
+SUBDIRS = \
        none
 
+THREAD_LIB = \
+       none/libthreadsnone.la
+endif
+
+
+noinst_LTLIBRARIES = \
+       libthreads.la
+
 if ENABLE_THREADS
-SUBDIRS = native
+libthreads_la_SOURCES = \
+       atomic.cpp \
+       atomic.hpp \
+       condition.hpp \
+       lock.cpp \
+       lock.hpp \
+       lockword.cpp \
+       lockword.hpp \
+       removeme.cpp \
+       mutex.hpp \
+       threadlist.cpp \
+       threadlist.hpp \
+       thread-classpath.cpp \
+       thread-classpath.hpp \
+       thread-cldc11.cpp \
+       thread-cldc11.hpp \
+       thread-openjdk.cpp \
+       thread-openjdk.hpp \
+       thread.cpp \
+       thread.hpp
 else
-SUBDIRS = none
+libthreads_la_SOURCES =
 endif
 
+libthreads_la_LIBADD = \
+       $(THREAD_LIB)
+
 
 ## Local variables:
 ## mode: Makefile