* src/threads/posix/thread-posix.cpp, src/threads/thread.cpp,
[cacao.git] / src / threads / Makefile.am
index 29f3701cf168101899a00fc336a87d7787ffbd91..98e8200b3b05e8d660ef9dd5584d5f57ff423da4 100644 (file)
@@ -26,26 +26,51 @@ AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/vm/jit/$(ARCH_DIR) -I$(top
 LIB =
 
 DIST_SUBDIRS = \
-       native \
-       none
+       none \
+       posix
+
+if ENABLE_THREADS
+SUBDIRS = \
+       posix
 
+THREAD_LIB = \
+       posix/libthreadsposix.la
+else
 SUBDIRS = \
-       native
+       none
 
 THREAD_LIB = \
-       native/libthreadsposix.la
+       none/libthreadsnone.la
+endif
+
 
 noinst_LTLIBRARIES = \
        libthreads.la
 
+if ENABLE_THREADS
 libthreads_la_SOURCES = \
-       critical.c \
-       critical.h \
-       lock-common.h \
-       threadlist.c \
-       threadlist.h \
-       threads-common.c \
-       threads-common.h
+       atomic.cpp \
+       atomic.hpp \
+       condition.hpp \
+       lock.cpp \
+       lock.hpp \
+       lockword.cpp \
+       lockword.hpp \
+       removeme.cpp \
+       mutex.hpp \
+       threadlist.cpp \
+       threadlist.hpp \
+       thread-classpath.cpp \
+       thread-classpath.hpp \
+       thread-cldc11.cpp \
+       thread-cldc11.hpp \
+       thread-openjdk.cpp \
+       thread-openjdk.hpp \
+       thread.cpp \
+       thread.hpp
+else
+libthreads_la_SOURCES =
+endif
 
 libthreads_la_LIBADD = \
        $(THREAD_LIB)