* src/threads/posix/thread-posix.cpp, src/threads/thread.cpp,
[cacao.git] / src / threads / Makefile.am
index 1aa9df94ff18e0e7ef59ebd9ca06be049a2a8ba3..98e8200b3b05e8d660ef9dd5584d5f57ff423da4 100644 (file)
@@ -49,12 +49,25 @@ noinst_LTLIBRARIES = \
 
 if ENABLE_THREADS
 libthreads_la_SOURCES = \
-       lock-common.h \
-       mutex.h \
-       threadlist.c \
-       threadlist.h \
-       thread.c \
-       thread.h
+       atomic.cpp \
+       atomic.hpp \
+       condition.hpp \
+       lock.cpp \
+       lock.hpp \
+       lockword.cpp \
+       lockword.hpp \
+       removeme.cpp \
+       mutex.hpp \
+       threadlist.cpp \
+       threadlist.hpp \
+       thread-classpath.cpp \
+       thread-classpath.hpp \
+       thread-cldc11.cpp \
+       thread-cldc11.hpp \
+       thread-openjdk.cpp \
+       thread-openjdk.hpp \
+       thread.cpp \
+       thread.hpp
 else
 libthreads_la_SOURCES =
 endif