- build/dist/install changes
[cacao.git] / src / native / Makefile.am
index 37705cfeaab1aec5f7ed68e124c743afdf5da6a7..8da106a4673d1e2d38efae75cf669c488bbe7afd 100644 (file)
@@ -1,6 +1,36 @@
-## Process this file with automake to produce Makefile.in
+## native/Makefile.am
+##
+## Copyright (C) 1996-2005 R. Grafl, A. Krall, C. Kruegel, C. Oates,
+## R. Obermaisser, M. Platter, M. Probst, S. Ring, E. Steiner,
+## C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich, J. Wenninger,
+## TU Wien
+##
+## This file is part of CACAO.
+##
+## This program is free software; you can redistribute it and/or
+## modify it under the terms of the GNU General Public License as
+## published by the Free Software Foundation; either version 2, or (at
+## your option) any later version.
+##
+## This program is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+## General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+## 02111-1307, USA.
+##
+## Contact: cacao@complang.tuwien.ac.at
+##
+## Authors: Christian Thalinger
+##
+## Changes:
+##
+## $Id: Makefile.am 1676 2004-12-03 16:52:15Z twisti $
 
-# $Id: Makefile.am 1655 2004-12-02 16:51:20Z carolyn $
+## Process this file with automake to produce Makefile.in
 
 INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/vm/jit/@ARCH_DIR@
 
@@ -13,7 +43,10 @@ noinst_LIBRARIES = libnative.a
 
 libnative_a_SOURCES = \
        jni.c \
-       native.c
+       jni.h \
+       native.c \
+       native.h \
+       nativecalls.inc
 
 native.c: nativetable.inc nativecalls.inc
 
@@ -21,7 +54,7 @@ if USE_GTK_PEER
 AWT_HEADERS_TOUCH_FILE = $(srcdir)/include/awtheaders-generated
 endif
 
-nativetable.inc: $(top_srcdir)/src/classpath/lib/bootstrap.zip $(top_srcdir)/config.h $(srcdir)/include/headers-generated $(AWT_HEADERS_TOUCH_FILE)
+nativetable.inc: $(top_srcdir)/src/classpath/lib/bootstrap.zip $(srcdir)/tools/gennativetable $(top_srcdir)/config.h $(srcdir)/include/headers-generated $(AWT_HEADERS_TOUCH_FILE)
        CLASSPATH=$(top_srcdir)/src/classpath/lib/bootstrap.zip \
        $(top_srcdir)/src/native/tools/gennativetable \
        $(NO_REGEN_CLASSES) \