* src/mm/boehm-gc/Makefile.am, src/mm/boehm-gc/libatomic_ops/Makefile.am:
[cacao.git] / src / mm / boehm-gc / Makefile.am
index cf83b26147f3d9bd6d6adaefbd4f0098221b3566..4679b05ccad47bf41807dd1f031f14adabf3b864 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright (c) 1999-2001 by Red Hat, Inc. All rights reserved.
-# 
+#
 # THIS MATERIAL IS PROVIDED AS IS, WITH ABSOLUTELY NO WARRANTY EXPRESSED
 # OR IMPLIED.  ANY USE IS AT YOUR OWN RISK.
-# 
+#
 # Permission is hereby granted to use or copy this program
 # for any purpose,  provided the above notices are retained on all copies.
 # Permission to modify the code and to distribute modified code is granted,
 
 ## Process this file with automake to produce Makefile.in.
 
-ACLOCAL_AMFLAGS = -I m4
-
-DISTCLEANFILES = \
-       atomic_ops.c \
-       atomic_ops_sysdeps.S \
-       libatomic_ops
-
 ## FIXME: `make distcheck' in this directory will not currently work.
 ##     This is most likely to the explicit flags passed to submakes.
 
@@ -30,7 +23,7 @@ DISTCLEANFILES = \
 # use the internal version.  This is done since libatomic_ops doesn't
 # use libtool, since it has no real use for it.  But that seems to make
 # it hard to use either the resulting object files or libraries.
-# Thus there seems too be no real reason to recusively build in the
+# Thus there seems too be no real reason to recursively build in the
 # libatomic_ops directory.
 # if USE_INTERNAL_LIBATOMICS_OPS
 # SUBDIRS = @maybe_libatomic_ops@
@@ -38,20 +31,27 @@ DISTCLEANFILES = \
 # SUBDIRS =
 # endif
 SUBDIRS =
+DIST_SUBDIRS = libatomic_ops
+
+ACLOCAL_AMFLAGS = -I m4
+AM_CPPFLAGS = -I$(top_builddir)/include -I$(top_srcdir)/include
+if USE_INTERNAL_LIBATOMIC_OPS
+AM_CPPFLAGS += -I$(top_builddir)/libatomic_ops/src \
+              -I$(top_srcdir)/libatomic_ops/src
+endif
 
 # Initialize variables so that we can declare files locally.
-EXTRA_DIST = 
+EXTRA_DIST =
+lib_LTLIBRARIES =
 noinst_LTLIBRARIES =
-# Don't install include/gc
-#include_HEADERS =
-#pkginclude_HEADERS =
+include_HEADERS =
+pkginclude_HEADERS =
 dist_noinst_HEADERS =
 check_PROGRAMS =
 TESTS =
 
-# Don't install pkg-config data.
-#pkgconfigdir = $(libdir)/pkgconfig
-#dist_pkgconfig_DATA = bdw-gc.pc
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = bdw-gc.pc
 
 # C Library
 # ---------
@@ -80,17 +80,17 @@ if WIN32_THREADS
 libgc_la_SOURCES += win32_threads.c
 endif
 
-if USE_INTERNAL_LIBATOMIC_OPS   
-nodist_libgc_la_SOURCES = ./atomic_ops.c        
-endif   
+if USE_INTERNAL_LIBATOMIC_OPS
+nodist_libgc_la_SOURCES = libatomic_ops/src/atomic_ops.c
+endif
 
-if NEED_ATOMIC_OPS_ASM          
-nodist_libgc_la_SOURCES = ./atomic_ops_sysdeps.S        
+if NEED_ATOMIC_OPS_ASM
+nodist_libgc_la_SOURCES = libatomic_ops/src/atomic_ops_sysdeps.S
 endif
 
 # Include THREADDLLIBS here to ensure that the correct versions of
 # linuxthread semaphore functions get linked:
-libgc_la_LIBADD = @addobjs@ $(THREADDLLIBS) $(UNWINDLIBS)
+libgc_la_LIBADD = @addobjs@ $(THREADDLLIBS) $(UNWINDLIBS) $(ATOMIC_OPS_LIBS)
 libgc_la_DEPENDENCIES = @addobjs@
 libgc_la_LDFLAGS = $(extra_ldflags_libgc) -version-info 1:3:0 -no-undefined
 
@@ -104,8 +104,8 @@ EXTRA_libgc_la_SOURCES = alpha_mach_dep.S \
 # -------------
 
 if CPLUSPLUS
-noinst_LTLIBRARIES += libgccpp.la
-#pkginclude_HEADERS += include/gc_cpp.h include/gc_allocator.h
+lib_LTLIBRARIES += libgccpp.la
+pkginclude_HEADERS += include/gc_cpp.h include/gc_allocator.h
 libgccpp_la_SOURCES = gc_cpp.cc
 libgccpp_la_LIBADD = ./libgc.la
 libgccpp_la_LDFLAGS = -version-info 1:3:0 -no-undefined
@@ -120,12 +120,11 @@ EXTRA_DIST += gc_cpp.cpp
 # Misc
 # ----
 
-#AM_CXXFLAGS = @GC_CFLAGS@
-#AM_CFLAGS = @GC_CFLAGS@
-AM_CPPFLAGS = -I$(top_builddir)/include -I$(top_builddir)/libatomic_ops/src
+AM_CXXFLAGS = @GC_CFLAGS@
+AM_CFLAGS = @GC_CFLAGS@
 
 ## FIXME: relies on internal code generated by automake.
-## FIXME: ./configure --enable-dependency-tracking should be used 
+## FIXME: ./configure --enable-dependency-tracking should be used
 #all_objs = @addobjs@ $(libgc_la_OBJECTS)
 #$(all_objs) : include/private/gcconfig.h include/private/gc_priv.h \
 #include/private/gc_hdrs.h include/gc.h include/gc_gcj.h \
@@ -171,37 +170,33 @@ EXTRA_DIST += README.QUICK
 
 # other makefiles
 # :GOTCHA: deliberately we do not include 'Makefile'
-EXTRA_DIST += BCC_MAKEFILE NT_MAKEFILE NT_THREADS_MAKEFILE \
+EXTRA_DIST += BCC_MAKEFILE NT_MAKEFILE \
     OS2_MAKEFILE PCR-Makefile digimars.mak EMX_MAKEFILE        \
     Makefile.direct Makefile.dj        Makefile.DLLs SMakefile.amiga \
-    WCC_MAKEFILE configure_atomic_ops.sh \
+    WCC_MAKEFILE build_atomic_ops.sh build_atomic_ops.sh.cygwin \
     NT_STATIC_THREADS_MAKEFILE NT_X64_STATIC_THREADS_MAKEFILE \
     NT_X64_THREADS_MAKEFILE
 
 # files used by makefiles other than Makefile.am
 #
-EXTRA_DIST += add_gc_prefix.c gcname.c if_mach.c if_not_there.c \
-    hpux_test_and_clear.s gc.mak MacOS.c \
-    MacProjects.sit.hqx mach_dep.c setjmp_t.c \
-    threadlibs.c AmigaOS.c \
+EXTRA_DIST += extra/add_gc_prefix.c extra/gc.c extra/gcname.c \
+    extra/if_mach.c extra/if_not_there.c hpux_test_and_clear.s gc.mak \
+    extra/MacOS.c MacProjects.sit.hqx mach_dep.c extra/setjmp_t.c \
+    extra/threadlibs.c extra/AmigaOS.c \
     Mac_files/datastart.c Mac_files/dataend.c \
     Mac_files/MacOS_config.h Mac_files/MacOS_Test_config.h \
-    include/private/msvc_dbg.h msvc_dbg.c
+    include/private/msvc_dbg.h extra/msvc_dbg.c
 
 # The libatomic_ops library.  This is not ideal, since we pick up junk from
-# there.  The hard-coded version number should also go.
-EXTRA_DIST += libatomic_ops-1.2
+# there.
+EXTRA_DIST += libatomic_ops
 
 # this is an auxiliary shell file used by Makefile and Makefile.direct
 #
 CONFIG_STATUS_DEPENDENCIES = $(srcdir)/configure.host
 
-# :FIXME: why do we distribute this one???
-#
-#EXTRA_DIST += libtool.m4
-
 #
-# :GOTCHA: GNU make rule for making .s out of .S is flawed, 
+# :GOTCHA: GNU make rule for making .s out of .S is flawed,
 # it will not remove dest if building fails
 .S.s:
        if $(CPP) $< >$@ ; then :; else rm -f $@; fi
@@ -212,5 +207,3 @@ include tests/tests.am
 include doc/doc.am
 # Putting these at the top causes cord to be built first, and not find libgc.a
 # on HP/UX.  There may be a better fix.
-
-