- build/dist/install changes
[cacao.git] / src / cacao / Makefile.am
index 6d0c0fcd36f46e28f586d27036da0564c07a519e..0ab02d3f0ef8ec8fad47b1ee785ac25639a7586f 100644 (file)
@@ -1,10 +1,39 @@
-## Process this file with automake to produce Makefile.in
+## cacao/Makefile.am
+##
+## Copyright (C) 1996-2005 R. Grafl, A. Krall, C. Kruegel, C. Oates,
+## R. Obermaisser, M. Platter, M. Probst, S. Ring, E. Steiner,
+## C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich, J. Wenninger,
+## TU Wien
+##
+## This file is part of CACAO.
+##
+## This program is free software; you can redistribute it and/or
+## modify it under the terms of the GNU General Public License as
+## published by the Free Software Foundation; either version 2, or (at
+## your option) any later version.
+##
+## This program is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+## General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+## 02111-1307, USA.
+##
+## Contact: cacao@complang.tuwien.ac.at
+##
+## Authors: Christian Thalinger
+##
+## Changes:
+##
+## $Id: Makefile.am 1676 2004-12-03 16:52:15Z twisti $
 
-# $Id: Makefile.am 1646 2004-12-01 16:02:23Z twisti $
+## Process this file with automake to produce Makefile.in
 
 INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/vm/jit/@ARCH_DIR@
 
-
 if USE_THREADS
 if NATIVE_THREADS
 THREAD_LIB = $(top_srcdir)/src/threads/native/libthreads.a
@@ -15,7 +44,6 @@ else
 THREAD_LIB =
 endif
 
-
 if STATIC_CLASSPATH
 cacao_LDFLAGS =
 CLASSPATH_LIBS = \
@@ -36,7 +64,6 @@ cacao_LDFLAGS = -ldl -Wl,--export-dynamic
 CLASSPATH_LIBS =
 endif
 
-
 if USE_GTK_PEER
 cacao_LDFLAGS += \
        -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 \
@@ -44,10 +71,13 @@ cacao_LDFLAGS += \
        -lgthread-2.0 -lart_lgpl_2
 endif
 
+bindir = $(prefix)/jre/bin
 
 bin_PROGRAMS = cacao
 
-cacao_SOURCES = cacao.c
+cacao_SOURCES = \
+       cacao.c \
+       cacao.h
 
 cacao_LDADD = \
        $(top_srcdir)/src/mm/libmm.a \