* configure.ac: New switch for disabling -O2 (--disable-optimizations).
[cacao.git] / src / Makefile.am
index 70577a975aa4187c374319a5b42b9bfc02e179c1..b1bf2b10609d14a455453926493e4c9dd795cd6b 100644 (file)
@@ -1,9 +1,7 @@
 ## src/Makefile.am
 ##
-## Copyright (C) 1996-2005, 2006 R. Grafl, A. Krall, C. Kruegel,
-## C. Oates, R. Obermaisser, M. Platter, M. Probst, S. Ring,
-## E. Steiner, C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich,
-## J. Wenninger, Institut f. Computersprachen - TU Wien
+## Copyright (C) 1996-2005, 2006, 2007, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
 ##
 ## This file is part of CACAO.
 ##
 ## along with this program; if not, write to the Free Software
 ## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
 ## 02110-1301, USA.
-##
-## Contact: cacao@cacaojvm.org
-##
-## Authors: Christian Thalinger
-##
-## Changes:
-##
-## $Id: Makefile.am 4357 2006-01-22 23:33:38Z twisti $
 
-## Process this file with automake to produce Makefile.in
 
 DIST_SUBDIRS = \
-       boehm-gc \
-       lib \
+       cacao \
+       classes \
        fdlibm \
        mm \
-       toolbox \
-       vm \
-       threads \
-       cacaoh \
        native \
-       cacao \
-       scripts
-
-if DISABLE_GC
-BOEHM =
-else
-BOEHM = boehm-gc
-endif
+       scripts \
+       threads \
+       toolbox \
+       vm
 
-# Keep this order!!!
+# DON'T CHANGE THIS ORDER!!!
 
 SUBDIRS = \
-       $(BOEHM) \
-       lib \
+       classes \
        fdlibm \
-       mm \
        toolbox \
+       mm \
        vm \
        threads \
-       cacaoh \
        native \
        cacao \
        scripts