* configure.ac: New switch for disabling -O2 (--disable-optimizations).
[cacao.git] / src / Makefile.am
index 5101ed01027ec118171af166764d301546bc4444..b1bf2b10609d14a455453926493e4c9dd795cd6b 100644 (file)
@@ -1,8 +1,49 @@
-## Process this file with automake to produce Makefile.in
+## src/Makefile.am
+##
+## Copyright (C) 1996-2005, 2006, 2007, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
+##
+## This file is part of CACAO.
+##
+## This program is free software; you can redistribute it and/or
+## modify it under the terms of the GNU General Public License as
+## published by the Free Software Foundation; either version 2, or (at
+## your option) any later version.
+##
+## This program is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+## General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+## 02110-1301, USA.
 
-# $Id: Makefile.am 1622 2004-11-30 13:18:52Z twisti $
 
-SUBDIRS = boehm-gc classpath mm toolbox vm threads cacaoh native cacao
+DIST_SUBDIRS = \
+       cacao \
+       classes \
+       fdlibm \
+       mm \
+       native \
+       scripts \
+       threads \
+       toolbox \
+       vm
+
+# DON'T CHANGE THIS ORDER!!!
+
+SUBDIRS = \
+       classes \
+       fdlibm \
+       toolbox \
+       mm \
+       vm \
+       threads \
+       native \
+       cacao \
+       scripts
 
 
 ## Local variables: