* configure.ac: New switch for disabling -O2 (--disable-optimizations).
[cacao.git] / src / Makefile.am
index 20d29e14432e192fe824c01093818f5afb3e9713..b1bf2b10609d14a455453926493e4c9dd795cd6b 100644 (file)
@@ -1,9 +1,7 @@
 ## src/Makefile.am
 ##
-## Copyright (C) 1996-2005 R. Grafl, A. Krall, C. Kruegel, C. Oates,
-## R. Obermaisser, M. Platter, M. Probst, S. Ring, E. Steiner,
-## C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich, J. Wenninger,
-## Institut f. Computersprachen - TU Wien
+## Copyright (C) 1996-2005, 2006, 2007, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
 ##
 ## This file is part of CACAO.
 ##
 ##
 ## You should have received a copy of the GNU General Public License
 ## along with this program; if not, write to the Free Software
-## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
-## 02111-1307, USA.
-##
-## Contact: cacao@complang.tuwien.ac.at
-##
-## Authors: Christian Thalinger
-##
-## Changes:
-##
-## $Id: Makefile.am 3964 2005-12-20 23:34:05Z twisti $
+## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+## 02110-1301, USA.
 
-## Process this file with automake to produce Makefile.in
 
 DIST_SUBDIRS = \
-       boehm-gc \
-       lib \
+       cacao \
+       classes \
        fdlibm \
-       libltdl \
        mm \
-       toolbox \
-       vm \
-       threads \
-       cacaoh \
        native \
-       cacao \
-       scripts
-
-if DISABLE_GC
-BOEHM =
-else
-BOEHM = boehm-gc
-endif
+       scripts \
+       threads \
+       toolbox \
+       vm
 
-# Keep this order!!!
+# DON'T CHANGE THIS ORDER!!!
 
 SUBDIRS = \
-       $(BOEHM) \
-       lib \
+       classes \
        fdlibm \
-       libltdl \
-       mm \
        toolbox \
+       mm \
        vm \
        threads \
-       cacaoh \
        native \
        cacao \
        scripts