* configure.ac: Some maintenance for make dist.
[cacao.git] / doc / Makefile.am
index a506ebcc3f079906c770f466a8f92965d2fbe0f8..a84caae7a9912dec432310ce2ffc0d3849fa82a6 100644 (file)
@@ -1,9 +1,7 @@
 ## doc/Makefile.am
 ##
-## Copyright (C) 1996-2005, 2006 R. Grafl, A. Krall, C. Kruegel,
-## C. Oates, R. Obermaisser, M. Platter, M. Probst, S. Ring,
-## E. Steiner, C. Thalinger, D. Thuernbeck, P. Tomsich, C. Ullrich,
-## J. Wenninger, Institut f. Computersprachen - TU Wien
+## Copyright (C) 1996-2005, 2006, 2008
+## CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
 ##
 ## This file is part of CACAO.
 ##
 ## along with this program; if not, write to the Free Software
 ## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
 ## 02110-1301, USA.
-##
-## Contact: cacao@cacaojvm.org
-##
-## Authors: Christian Thalinger
-##
-## Changes:
 
-## Process this file with automake to produce Makefile.in
 
-SUBDIRS = handbook
+SUBDIRS = \
+       doxygen \
+       handbook
+
+dist_noinst_DATA = \
+       assertions.tex \
+       annotations.tex \
+       jsr.bib
+
+EXTRA_DIST = \
+       design_onstack_replacement.txt \
+       inlining_stacktrace.txt \
+       native_threads.txt \
+       stack.txt \
+       stack_frames.txt
+
+CLEANFILES = \
+       annotations.aux \
+       annotations.bbl \
+       annotations.blg \
+       annotations.dvi \
+       annotations.lof \
+       annotations.log \
+       annotations.lot \
+       annotations.toc \
+       annotations.idx \
+       annotations.out \
+       annotations.tex~ \
+       assertions.aux \
+       assertions.dvi \
+       assertions.log \
+       assertions.toc
 
-EXTRA_DIST = inlining_stacktrace.txt native_threads.txt stack.txt
+annotations:
+       latex annotations
+       bibtex annotations
+       latex annotations
+       latex annotations
 
+assertions:
+       latex assertions
+       latex assertions
 
 ## Local variables:
 ## mode: Makefile