so far for ppc
[archlinuxppc.git] / hugs98 / PKGBUILD
1 # Contributor: Tom Newsom <Jeepster@gmx.co.uk>
2 # Contributor: Kevin Piche <kevin@archlinux.org>
3
4 pkgname=hugs98
5 pkgver=200609
6 pkgrel=4
7 pkgdesc="Haskell 98 interpreter"
8 arch=('i686' 'x86_64' 'ppc')
9 url="http://www.haskell.org/hugs"
10 license=('custom')
11 depends=('readline>=6.0' 'sh')
12 source=(http://cvs.haskell.org/Hugs/downloads/2006-09/$pkgname-plus-Sep2006.tar.gz)
13 md5sums=('e03e0ad79750d037237c47ebe33fa20e')
14
15 build() {
16   if [ "$CARCH" = "x86_64" ]; then
17     unset CFLAGS
18   fi
19
20   cd $startdir/src/$pkgname-plus-Sep2006
21   #rm config.cache
22   ./configure --prefix=/usr --with-pthreads 
23   make  || return 1
24   make DESTDIR=$startdir/pkg install
25   
26   install -Dm644 License ${pkgdir}/usr/share/licenses/hugs98/license
27 }