Rename lxbios to nvramtool, step 3 (rename directory).
[coreboot.git] / util / nvramtool / nvramtool.spec
1 ##
2 # $Id$
3 ##
4
5 Name:    nvramtool
6 Version: 2.0.1
7 Release: 0
8
9 Summary: coreboot utility program
10 Group:   System Environment/Base
11 License: GPL
12 Provides: nvramtool
13
14 BuildRoot: %{_tmppath}/%{name}-%{version}
15
16 Source0: %{name}-%{version}.tgz
17
18 %description
19 nvramtool is a utility for reading/writing coreboot parameters and displaying
20 information from the coreboot table.
21
22 At boot time, coreboot places a table (known as the coreboot table) in low
23 physical memory.  The contents of this table are preserved even after
24 coreboot transfers control to the kernel and the kernel initializes itself.
25 The coreboot table contains various system information such as the type of
26 mainboard in use.  It also specifies locations in the CMOS (nonvolatile RAM)
27 where the coreboot parameters are stored.
28
29 %prep
30 %setup -n %{name}-%{version}
31
32 %build
33 make
34
35 %install
36 rm -rf "$RPM_BUILD_ROOT"
37 mkdir -p "$RPM_BUILD_ROOT/usr/bin"
38 mkdir -p "$RPM_BUILD_ROOT/usr/man/man1"
39 cp nvramtool "$RPM_BUILD_ROOT/usr/bin"
40 cp nvramtool.1.gz $RPM_BUILD_ROOT/usr/man/man1
41
42 %clean
43 rm -rf "$RPM_BUILD_ROOT"
44
45 %files
46 %defattr(-,root,root,0755)
47 %doc ChangeLog README
48 %doc README
49 /usr/bin/nvramtool
50 /usr/man/man1/nvramtool.1.gz