new stuff
[archlinuxppc.git] / lhs2tex / PKGBUILD
diff --git a/lhs2tex/PKGBUILD b/lhs2tex/PKGBUILD
new file mode 100644 (file)
index 0000000..0861430
--- /dev/null
@@ -0,0 +1,24 @@
+# Maintainer: Arch Haskell Team <arch-haskell@haskell.org>
+_hkgname=lhs2tex
+pkgname=lhs2tex
+pkgver=1.16
+pkgrel=1
+pkgdesc="Preprocessor for typesetting Haskell sources with LaTeX"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('GPL')
+arch=('i686' 'x86_64' 'ppc')
+makedepends=('ghc' 'haskell-directory' 'haskell-extensible-exceptions' 'haskell-filepath' 'haskell-mtl' 'haskell-process' 'haskell-regex-compat')
+depends=('gmp')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+build() {
+    cd ${srcdir}/${_hkgname}-${pkgver}
+       ghc --make Setup.hs
+    ./Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O
+    ./Setup build
+}
+package() {
+    cd ${srcdir}/${_hkgname}-${pkgver}
+    ./Setup copy --destdir=${pkgdir}
+}
+md5sums=('d9a328cf54341a6722715411a195c2cc')